[RESOLVED] Installation error 0xfffffff7

Any issues, problems or troubleshooting topics related to installing the Prepar3D client application or it's installer.
User avatar
iceman14555
Posts: 2
Joined: Thu Oct 01, 2015 6:04 pm

[RESOLVED] Installation error 0xfffffff7

Postby iceman14555 » Thu Oct 01, 2015 6:17 pm

Hello,

I am trying to install V3 and keep receiving the above error code, which is an unspecified error. I have done a search of the forum and google. I found one article suggesting to install the redist packages from the package cache manually. Unfortunately the package that is throwing the error is not in the package cache. Is this a corrupt download or do I need to look elsewhere for the package.

Here is the error part of the log:

[076C:0F6C][2015-10-01T13:44:22]i301: Applying execute package: VCREDIST120, action: Install, path: C:\ProgramData\Package Cache\DF7F0A73BFA077E483E51BFB97F5E2ECEEDFB6A3\vcredist_x86.exe, arguments: '"C:\ProgramData\Package Cache\DF7F0A73BFA077E483E51BFB97F5E2ECEEDFB6A3\vcredist_x86.exe" /q'
[0FB0:138C][2015-10-01T13:44:23]i319: Applied execute package: VCREDIST120, result: 0x0, restart: None
[076C:0F6C][2015-10-01T13:44:23]i301: Applying execute package: DirectX, action: Install, path: C:\ProgramData\Package Cache\9FD00F3BB8A870112DAE464F555FCD5E7F9200C0\redist\DXSETUP.exe, arguments: '"C:\ProgramData\Package Cache\9FD00F3BB8A870112DAE464F555FCD5E7F9200C0\redist\DXSETUP.exe" /silent'
[076C:0F6C][2015-10-01T13:45:40]e000: Error 0xfffffff7: Process returned error: 0xfffffff7
[076C:0F6C][2015-10-01T13:45:40]e000: Error 0xfffffff7: Failed to execute EXE package.
[0FB0:138C][2015-10-01T13:45:40]e000: Error 0xfffffff7: Failed to configure per-machine EXE package.
[0FB0:138C][2015-10-01T13:45:40]i319: Applied execute package: DirectX, result: 0xfffffff7, restart: None
[0FB0:138C][2015-10-01T13:45:40]e000: Error 0xfffffff7: Failed to execute EXE package.
[076C:0F6C][2015-10-01T13:45:40]i351: Removing cached package: DirectX, from path: C:\ProgramData\Package Cache\9FD00F3BB8A870112DAE464F555FCD5E7F9200C0\
[076C:0F6C][2015-10-01T13:45:41]i351: Removing cached package: VCREDIST120, from path: C:\ProgramData\Package Cache\DF7F0A73BFA077E483E51BFB97F5E2ECEEDFB6A3\
[076C:0F6C][2015-10-01T13:45:41]i330: Removed bundle dependency provider: {ef7923e2-4857-4683-820d-a3994d88d709}
[076C:0F6C][2015-10-01T13:45:41]i352: Removing cached bundle: {ef7923e2-4857-4683-820d-a3994d88d709}, from path: C:\ProgramData\Package Cache\{ef7923e2-4857-4683-820d-a3994d88d709}\
[0FB0:138C][2015-10-01T13:45:41]i399: Apply complete, result: 0xfffffff7, restart: None, ba requested restart: No

Here are my PC specs:

Windows 10 Home
AMD FX8320 4.2Ghz CPU
ASUS Sabertooth 990FX mobo
EVGA GTX 760 SC
8gb G.Skill Sniper memory

User avatar
iceman14555
Posts: 2
Joined: Thu Oct 01, 2015 6:04 pm

Re: Installation error 0xfffffff7 (EDITED)

Postby iceman14555 » Thu Oct 01, 2015 7:27 pm

Well further digging, no thanks to Google (you have failed me), I found the fixes. If you are having a similar problem these are the steps:

1) Install the Client, Content, and Scenery MSI's manually, in that order.
2) Set the P3d.exe properties to run as admin.
3) start the program, it should ask for activation, enter your credentials and you should get a "activation successful."

Hope this helps others.

buggyman
Posts: 5
Joined: Sat Aug 25, 2012 2:26 pm

Re: Installation error 0xfffffff7

Postby buggyman » Fri Oct 02, 2015 7:53 am

I had a similar problem and after looking back at my notes on v2 I remembered that there seemed to be a conflict with my anti virus software and P3D.

So I temporarily disabled my anti virus - Kaspersky - and tried again. Result!! V3 installed faultlessly.

You may like to try the above - sometimes its the simple things that work.

Allan

Oh yes - don't forget to turn your anti virus back on again. :)

MicTea
Posts: 1
Joined: Sat Oct 03, 2015 8:34 pm

Re: Installation error 0xfffffff7

Postby MicTea » Sat Oct 03, 2015 8:38 pm

buggyman wrote:So I temporarily disabled my anti virus - Kaspersky - and tried again. Result!! V3 installed faultlessly.


Same here. I also tried to disable Kaspersky temporarily but without solving the issue.
Important: make sure to close the Kaspersky application entirely, not stopping protection temporarily!

That worked for me.

User avatar
Raphael_Chacon
Posts: 73
Joined: Tue Apr 07, 2015 5:40 pm

Re: Installation error 0xfffffff7

Postby Raphael_Chacon » Sat Oct 03, 2015 9:35 pm

Worked here,

No errors after disabling and closing manually Kaspersky AV.

:-)
Image
INV-2071056

Easystrider
Posts: 3
Joined: Thu Aug 30, 2012 10:57 am

Re: Installation error 0xfffffff7

Postby Easystrider » Sat Oct 03, 2015 10:08 pm

Hi all.

I got the same error when trying to install v3.
Disabled and closed antivirus (Avast) and still recieve the same error.
Ran setup as administrator....same error.

Tried just running client setup and I then recieve the error:
"Registry key could not be opened/created or is missing (9217)".

In between tries I have cleaned out any setup files left from the failed attempts.

Have been using P3D v2.5 with no problems on Windows 10 64bit for some time now.

Frustrated....Yes!

Norwegian737Project
Posts: 3
Joined: Mon Mar 09, 2015 7:51 pm
Location: Norway
Contact:

Re: Installation error 0xfffffff7

Postby Norwegian737Project » Wed Oct 14, 2015 12:19 am

I have the exact same problem.

Please help..

Win 7, No antivirus, No firewalls, ran as administrator, downloaded using IDM.. Nothing helps..

Norwegian737Project
Posts: 3
Joined: Mon Mar 09, 2015 7:51 pm
Location: Norway
Contact:

Re: Installation error 0xfffffff7

Postby Norwegian737Project » Wed Oct 14, 2015 7:25 am

Disable automatic startup of Teamviewer..

Went to msconfig and disabled the startup. Rebooted, and baam.. P3D finally installed..

I had this: teamviewer_service.exe *32 running in the background..


Return to “Prepar3D Installation and Installer Questions”

Who is online

Users browsing this forum: Google [Bot] and 12 guests