[RESOLVED] Win7 - Updated Nvidia drivers/4.5 FPS P3D 3.4.1

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
SWA4420
Posts: 37
Joined: Mon Mar 10, 2014 5:56 pm

[RESOLVED] Win7 - Updated Nvidia drivers/4.5 FPS P3D 3.4.1

Postby SWA4420 » Mon Dec 05, 2016 12:12 am

Hello All,

I have updated my NVidia GTX970 card to the latest driver version 376.09, released on 11/27/16, and my FPS has dropped to 4.5. I deleted the shaders folder from user/appdata/local/Lockheed Martin/Prepar3D v3, but no change. I did an express installation over the previous drivers on my system, which I updated a few months back. There was no problem using the previous drivers as far as FPS was concerned....I'm locked at 40, and was getting near that most of the time.

Strangely, if I click off the P3D window, the FPS jumps up to near 40 and maintains it, and I can fly aircraft using my flight control hardware, but when I click back into the P3D window, FPS goes back to 4.5. Also, when I try to change the airport, I cannot - everything freezes. But I can select a different aircraft....weird....

My system specs: Win7-64, 16GB RAM, NVidia GTX970 4GB VRAM using surround for 3 monitors @ 5760x1080x32, i7-4790 @ 3.6GHz, Saitek Cessna Yoke/Throttle/Rudder Pedals/GoFlight Airliner setup w/dual EFIS, CPFlight Airbus FCU/dual EFIS.

Any ideas/suggestions to solve this strange problem (other than reloading the drivers from the card's install CD, that is).

Thanks,
Jim

Poppet
Lockheed Martin
Posts: 1252
Joined: Sat Nov 01, 2014 4:12 pm

Re: Win7 - Updated Nvidia drivers/4.5 FPS P3D 3.4.1

Postby Poppet » Mon Dec 05, 2016 7:34 am

Hello Jim,

After you Updated your Graphics Driver did you Delete your Prepar3D.cfg ? (Recommended)

Right click and Delete it, It will build again as Default when you launch Prepar3D

Location: Local Disk (C:) ► Users ► You ► AppData ► Roaming ► Lockheed Martin ► PreparD v3 Prepar3D.cfg

============

If you are still having Issues.......

If Prepar3D was working perfect before you Updated your Drivers the Quickest thing to do is Reinstall your Driver and Ticking the box for Perform a Clean Installation Or using a Tool like Driver Display Uninstaller to clean out your old Drivers before you Reinstall again.

Obviously with the above action you would Test with the same (Updated) driver again and maybe Roll back one driver and test also
Elaine Dixon
Prepar3D® Forum Global Moderator

SWA4420
Posts: 37
Joined: Mon Mar 10, 2014 5:56 pm

Re: Win7 - Updated Nvidia drivers/4.5 FPS P3D 3.4.1

Postby SWA4420 » Mon Dec 05, 2016 5:43 pm

Hi Elaine,

I wound up doing a system restore to get the older drivers back, and things have returned to normal. I noted the exact same symptoms running FSX-SE after updating, and after system restore, it's working normally again as well. X-Plane 10.45 was not affected by the update or the restore.

So for the time being, I'm keeping things as they are...if it's not broken, there's no need to "fix" it...!

Thanks for your recommendation of deleting the prepar3d.cfg file, as I'll file that one away for the future, as this machine is going on two years old now.

Thanks,
Jim

Ldee247
Posts: 7
Joined: Wed Oct 22, 2014 5:28 pm

Re: Win7 - Updated Nvidia drivers/4.5 FPS P3D 3.4.1

Postby Ldee247 » Wed Dec 14, 2016 8:41 am

Hi Jim,

Hi,I just came across your post today I'm also in the same scenario I updated my driver to 376.19 and now my p3d v3.4 its taking forever to load up and frames are hoping up and down. I've tried deleting p3d.cfg and rebuild a new one but still the same thing.

I also play war thunder and realised that my frames are doing the same thing,screen and mouse lagging.

I'm curious what stable driver was you using before the update I may also try revert to that version probably my issue will be solved.

Thanks in advance
Regards
Lloyd

SWA4420
Posts: 37
Joined: Mon Mar 10, 2014 5:56 pm

Re: Win7 - Updated Nvidia drivers/4.5 FPS P3D 3.4.1

Postby SWA4420 » Wed Dec 14, 2016 5:54 pm

Hi Lloyd,

The previous driver was 368.22, downloaded on 6/2/16.

An update - I decided to give their latest driver 376.19 another try, and deleted both the shaders folder and p3d.cfg (did the same with the two shader folders and fsx.cfg for my FSX-SE), and everything is working well on both sims.

Good luck,
Jim

shammerton
Posts: 17
Joined: Sat Feb 11, 2012 9:58 am

Re: Win7 - Updated Nvidia drivers/4.5 FPS P3D 3.4.1

Postby shammerton » Sun Jan 01, 2017 12:25 pm

SWA4420 wrote:Strangely, if I click off the P3D window, the FPS jumps up to near 40 and maintains it, and I can fly aircraft using my flight control hardware, but when I click back into the P3D window, FPS goes back to 4.5. Also, when I try to change the airport, I cannot - everything freezes. But I can select a different aircraft....weird....



I had the same issue and I reset the nvidia drivers back to the default settings and that resolved the issue. I'm not sure which nvidia parameter was the culprit.


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: Baidu [Spider] and 5 guests