Search found 17 matches

by mchriest
Tue Mar 19, 2019 2:58 pm
Forum: Prepar3D Feature Requests
Topic: Multiplayer Shaking and Jitter
Replies: 2
Views: 2015

Re: Multiplayer Shaking and Jitter

Hi, Host: Prepar3d v4.4.16 Professional Windows 7 Pro GeForce GTX 980 Player 1 Prepar3d v4.4.16 Professional Plus Windows 10 Pro GeForce RTX 2080 Local subnet (no routers, just a gigabit switch) Firewall disabled Experimenting with the demo "Multiplayer and SimOperator Base Scenario" (Host + 1 playe...
by mchriest
Thu Nov 08, 2018 7:20 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Articulated Parts - P3D as IG
Replies: 9
Views: 5630

Re: CIGI Articulated Parts - P3D as IG

Hi Brady, thanks for testing, and thanks for the reply. As long as I know that the features work when configured correctly, I'm happy to continue trying to figure out what the issue is on my end. I'll assume for now that when the articulated parts issue is resolved, I'll also resolve the camera offs...
by mchriest
Wed Nov 07, 2018 9:48 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Articulated Parts - P3D as IG
Replies: 9
Views: 5630

Re: CIGI Articulated Parts - P3D as IG

Hi Clifton, The simulation is in synchronous mode. Yes, the sim updates, and yes, I'm sending the IGCtrl packets. Nothing would work otherwise. If you have the time, please take a moment to review the other threads I have recently posted to: (Cigi Crash when using P3D as IG, and Cigi Object Renderin...
by mchriest
Mon Nov 05, 2018 8:39 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Articulated Parts - P3D as IG
Replies: 9
Views: 5630

Re: CIGI Articulated Parts - P3D as IG

Hi Clifton, thanks for the reply. I"m using my own host, based on the Cigi Class Library "CigiMiniHost" example. I am currently sending an Articulated Part packet every frame, modifying the left aileron setting. entityID = 0 ArtPartID = 2 (left ail, from the cigi art. parts. xml) ArtPartEn = 1 Pitch...
by mchriest
Fri Nov 02, 2018 7:04 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Articulated Parts - P3D as IG
Replies: 9
Views: 5630

Re: CIGI Articulated Parts - P3D as IG

Updated Observation: I can apply an articulated part deflection to the first packet received by P3D, but all subsequent packets are ignored. This is repeatable, and is not dependent on modifying the CigiArticulatedParts.xml. e.g., using Mooney Bravo. 1. Configure my host to send some deflection to t...
by mchriest
Fri Nov 02, 2018 5:02 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Articulated Parts - P3D as IG
Replies: 9
Views: 5630

CIGI Articulated Parts - P3D as IG

Using P3D as IG, My Articulated Parts packets are being ignored. Packet mapped to entity 0, Articulated part enabled, correct deflection axis (pitch, for AILERON_LEFT_DEFLECTION, in this case) enabled. ArticulatedPartID = 2. I note that the provided CigiArticulatedParts.xml provides definitions for ...
by mchriest
Tue Oct 30, 2018 3:35 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: Cigi Object Rendering
Replies: 3
Views: 4284

Re: Cigi Object Rendering

Hi Brady, First, I'd like to thank you very much for your helpful reply. Your suggested workaround results in the object being rendered, and I can now move forward with my work on articulated parts. I'm grateful for your help, and glad that P3D is providing support for cigi. That said, I'd consider ...
by mchriest
Tue Oct 30, 2018 1:30 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Crash when using P3D as IG
Replies: 7
Views: 4824

Re: CIGI Crash when using P3D as IG

Last week I resolved the issue of the scene not changing. The View Control packet was required, in addition to the View Def packet. My above comment regarding 1 packet per message is incorrect. The packets should be packed together in a single message. the cigi icd contradicts itself later, making t...
by mchriest
Fri Oct 26, 2018 8:54 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: Cigi Object Rendering
Replies: 3
Views: 4284

Cigi Object Rendering

Using P3D v4.3 pro plus as an IG via CIGI: Am connecting and flying using external host, but unable to view my aircraft. The ViewDef packet ViewID = 0, matching the ViewID in CigiConfig Using ExtendedType setting, I can confirm that my target aircraft is loaded, by noting the Cigi Aircraft view when...
by mchriest
Thu Oct 18, 2018 6:07 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Crash when using P3D as IG
Replies: 7
Views: 4824

Re: CIGI Crash when using P3D as IG

Yes, thanks. ViewID = 0 on both sides. I'll see what happens when I've broken the packets into separate packets.
by mchriest
Thu Oct 18, 2018 5:49 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Crash when using P3D as IG
Replies: 7
Views: 4824

Re: CIGI Crash when using P3D as IG

Hi Clifton. Thanks for the reply. FYI, P3D is no longer crashing, although I don't know why, and don't like that. I can tell you that this morning I put a breakpoint at the top of my host code, running in debugger, and stepped through the main loop. Got an SOF packet, as expected. sent data and back...
by mchriest
Wed Oct 17, 2018 9:49 pm
Forum: Prepar3D Professional Plus Client Application Questions
Topic: CIGI Crash when using P3D as IG
Replies: 7
Views: 4824

Re: CIGI Crash when using P3D as IG

I've been working with Lukas, and have independently attempted to configure p3d as a cigi IG. I've started with the CIGIMinitHost, provided as an example with the cigi class library, and am getting a similar result. After clicking StartIG, my host receives exactly one SOF message from P3D before P3D...
by mchriest
Fri Sep 18, 2015 9:40 pm
Forum: Simulation Object Development Questions
Topic: iSimObject propeller
Replies: 2
Views: 1892

iSimObject propeller

Has anyone implemented prop animation on an iSimObject aircraft? I am unable to animate props inside an iSimObject derived airplane. Animation mapping is all correct, verified by loading my exported .mdl in place of piper cub, where the prop works perfectly. However, when the model is loaded by an i...
by mchriest
Thu Mar 19, 2015 12:24 pm
Forum: Other Support Questions
Topic: Add-on Scenery Problem
Replies: 38
Views: 7391

Sorry about the previous, that link was for prepared version 1.x, your actual command would be for the folders associated with v2.
Apologize for the hasty mistake.
by mchriest
Thu Mar 19, 2015 12:22 pm
Forum: Other Support Questions
Topic: Add-on Scenery Problem
Replies: 38
Views: 7391

Scenery.cfg has been moved from the program root to "program data". Your scenery library installer hasn't been updated, and so can't find it. Easiest resolution is to use command line to create a symbolic link to the correct file. Open up CMD and enter the following command, assuming you are on driv...

Go to advanced search