Missiles are not guiding to their target... what do I have to set? [VIDEO]

Any issues, problems or troubleshooting topics related to the additional features present in the Prepar3D Professional Plus client application.
minime
Posts: 1198
Joined: Mon Jun 10, 2013 4:33 pm

Postby minime » Thu Jan 09, 2014 11:05 am

I set up a little test sandbox for my SAM systems to shoot at.



Although I managed to shoot SA-2 missiles from the launcher, they do not seem to guide to their targets objectID, although I set it on the launcher when triggering. The missiles in the video never appear again, they just fly somewhere. As the callbacks are broken, I never receive information about the missiles, so its kinda hard to do anything.



What do I need to do to fix that?



And also... how do I rearm the launcher? There is a reset event, but it does only rearm the ownship, or so it seems (which makes sense to me).



Video:



http://www.youtube.com/watch?v=orjzz94I9Mw



Thx!

Adam Breed
Lockheed Martin
Posts: 1385
Joined: Mon Sep 20, 2010 6:17 pm

Postby Adam Breed » Thu Jan 09, 2014 2:35 pm

Hi,



There could be a couple issues. First, the target ID might not be getting set. Second, the weapon might not be set to be guided (the stock V-750 missiles are). Finally, it must be in the guidance cones and have the correct guidance/aerodynamics/propulsion configurations. You can set a camera on the weapon and see if it is turning at all; if not, it is probably the first issue of the target ID not getting set.
Prepar3D® Engineering Project Manager

minime
Posts: 1198
Joined: Mon Jun 10, 2013 4:33 pm

Postby minime » Fri Jan 10, 2014 5:43 am

Thx a lot!



Seems to be a real world guidance problem. I thought they were in the envelope (as you can see in the video they are kind close) but obviously the missile didn't get there as it starts its insane climb and then runs out of envelope.



I have a confirmed shootdown now, so it is kinda working, even if I can't get the data back yet.

minime
Posts: 1198
Joined: Mon Jun 10, 2013 4:33 pm

Postby minime » Fri Jan 10, 2014 8:40 am

Oh, about setting a camera on the weapon: That is not working for me.



See these posts:



http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=4942

http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=4967



So if you have a code sample that will get me a working weapons camera, please let me know! (No usage of PDK allowed :P)



And if you mean selecting the weapon in the simulator with the right-click mouse options: That is not working either, because the SA-2 weapons are not in the weapons list, only the bombs and missiles from the aircraft are. After the SA-2 missile is flying, it is still not selectable.



Thx!


proussin
Posts: 31
Joined: Thu Sep 19, 2013 5:17 pm

Postby proussin » Fri Jan 24, 2014 2:54 pm

minime, I really am enjoying watching your progress. It looks like you are having great fun developing your ideas.



Best to you,



Paul

minime
Posts: 1198
Joined: Mon Jun 10, 2013 4:33 pm

Postby minime » Sat Jan 25, 2014 5:04 am



Quote:

Quote from proussin on January 24, 2014, 14:54

minime, I really am enjoying watching your progress. It looks like you are having great fun developing your ideas.



Best to you,



Paul




Haha... thx... yes. I do have fun in between, but mostly when stuff works. And that is usually my own code. :P



The problem is that I can only fix my own software and code, and that means while I have a wonderfully stable simulation server and instructor console, everything that interfaces into Prepar3d is either slightly unstable or not working because of bugs and missing API features.



Besides fixing the bugs I am just hoping LM is getting around to implementing all API calls into SimConnect that are needed for full access to Prepar3d.



There is just so much stuff in a 50% state. I think the problem is that Prepar3d is currently half way between a game and an engine. The API is not complete enough to call it a simulation engine, really, its more like a moddable game. But its on its way to being good, I am just not sure about the timeframe.



I will create some more videos soon that show what I can do already, its a lot and it looks quite good. But you will also see the bad things:



- Multiplayer is completely broken as soon as you add weapons

- Camera system is not working, thus no target cameras possible, no helmet mounted sights, no target marking on the ground

- AI API is very messy with no animations on AI aircraft possible, so you see transport aircraft with non moving engines and frozen helicopters

- Helicopters can not be created as flying entities, which creates tons of problems with cameras, animations and SimVars (no ATC SimVars)

- No way to add SimVars to existing SimObject categories so you cannot attach any state data to SimObjects by normal means



If stuff was just working and the API was complete, I would now be almost done with my work. But as it is, I still have tons of work and also tons of small tasks sitting in a "currently not possible" and "currently bugged" state, which really gets on my nerves.



So overall, my fun is limited right now. I am waiting for the magic patch that fixes it all. :)

But most of the serious API stuff they arent even working on as far as I know. :(



But yes, I will create a nice video and show some stuff, maybe you like it.


minime
Posts: 1198
Joined: Mon Jun 10, 2013 4:33 pm

Postby minime » Wed Jan 29, 2014 12:27 pm

Here is the video I promised:



http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=5284



Minime


Return to “Prepar3D Professional Plus Client Application Questions”

Who is online

Users browsing this forum: No registered users and 7 guests