Page 1 of 1

No DLL.XML in v4 installation....?

Posted: Fri Jun 30, 2017 2:28 pm
by 767Captain
Hello! I'm attempting to install and configure iFMS for use with P3Dv4. It requires that after copying the appropriate DLL to its folder in the main directory the DLL.XML file be edited with an entry pointing P3Dv4 to the XML file for running. Trouble is, when I look in the C:\Users\AppData\.....\Roaming\L-M\Prepar3D v4 folder there's no DLL.XML file there. So far I've added aircraft and sceneries but no additional modules like FSUIPC. So what to do? I could create one from scratch I suppose. Any thoughts?

Regards,

767Captain

Re: No DLL.XML in v4 installation....?

Posted: Fri Jun 30, 2017 3:07 pm
by Poppet
Hello 767Captain

You have both of these files by Default at the location below, You can launch your Add On from this location

Local Disk (C:) ► ProgramData ► Lockheed Martin ► Prepar3D v4 ► exe.xml dll.xml

-----------------------------


By Default you will Not have an exe.xml or a dll.xml file at the location below, But you can create your own .xml files and Insert them into this location.

Local Disk (C:) ► Users ► You ► AppData ► Roaming ► Lockheed Martin ► Prepar3D v4

The below Image shows you how to create an exe.xml file, Its the Same procedure for a dll.xml file

https://www.avsim.com/applications/core ... e70f236d81


You will now need a Header Code for these files, You can Copy and Paste the below entries into the .xml file you need for the Add On

exe.xml file
<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">
<Descr>Launch</Descr>
<Filename>EXE.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>


dll.xml file
<?xml version="1.0" encoding="WINDOWS-1252"?>

<SimBase.Document version="1,0" Type="Launch">
<Descr>Launch</Descr>
<Filename>dll.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>


For Example: After you insert your Add On launch entry Into your dll.xml it will look like this

You will need to change the <Name> and the <Path> to suite your name and path

<?xml version="1.0" encoding="WINDOWS-1252"?>

<SimBase.Document version="1,0" Type="Launch">
<Descr>Launch</Descr>
<Filename>dll.xml</Filename>
<Disabled>False</Disabled>
<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>
<Name>Poppets Add On</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>C:\Poppets folder\Popppet.exe</Path>
</Launch.Addon>

</SimBase.Document>