Search found 1 match: Panels always on top

Searched query: panels always on top

ignored: always on

by Beau Hollis
Thu Jan 05, 2017 1:02 pm
Forum: Prepar3D Client Application Questions
Topic: DXGI_ERROR_DEVICE_HUNG
Replies: 169
Views: 83387

Re: DXGI_ERROR_DEVICE_HUNG

Here are some things to try (In addition to Adams instructions)

If all or some of these fix the issue, that will help us narrow down the cause.
- Disable MSAA
- Turn off any custom driver overrides (especially AA settings)
- Disable NVSurround or EyeFinity if you are using it
- Hide the menu bar and close the ATC window
- Try running with only one monitor enabled

This information would also help use track things down:
- what is your GPU model and driver version?
- If multi-monitor or multi-gpu:
- which monitors are plugged into which gpu?
- what kind of windows/panels are on each monitor?
- does moving that app to another monitor affect your results?
- Are any driver overrides (such as AA overrides) being set
- Are window management features like nvsurround or eyefinity?
- if Win7, is there an Aero theme enabled? (eg transparent window title bars)

Finally, one more thing to try is to modify this entry in your prepar3d.cfg.
[PANELS]
PANELS_ALWAYS_ON_TOP=0

It may not be related, but we did modify our the window ordering code a bit for v3.4 to allow panels to stay on top of 3d views. It's possible these additional window ordering commands are tripping up some graphics drivers. This is an optional feature which can be disabled with the setting above.

Thanks again for your reports and your patients in dealing with this issue.

Return to “DXGI_ERROR_DEVICE_HUNG”