[RESOLVED] v3.1 severe memory leak!

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
User avatar
MyPC8MyBrain
Posts: 660
Joined: Sat Apr 06, 2013 4:05 pm
Location: Los Angeles, CA
Contact:

[RESOLVED] v3.1 severe memory leak!

Postby MyPC8MyBrain » Sat Jan 02, 2016 5:08 am

after chasing this issue for several days now,

it seems that 3.1 has a severe memory leak when accessing xml library object files,
Ive attached debug log from the start-up session including Night Environment Alps used for the testing,
the same exact files and scenario is loaded in 2min under v3.0!
under 3.1 as soon as the object library bgl is accessed initially the platform crawls to a halt;
the main window will appear none responsive and hand for a very long time;
if left alone the Sim will recover eventually and load the scenery,

Leaked session debug log http://nightenvironment.com/images/exte ... ect000.rar
(line 2737, 2738)

Code: Select all

< 14.48332 [384] Event: 4
< 584.31928 [384] Event: 10


Leaked session in 3.1 (clean install, default settings, Night Environment Alps)

Image


same scenario in 3.0 (clean install, default settings, Night Environment Alps)

Image


P3D v3.0 base, no addons (clean install, default settings)

Image

(my apologies for the missing debug log from 3.0; i couldn't get the debug log to work yesterday)

on a side note, great work fixing the night textures emissive night textures and 3D lights! LOVE IT!
Chris Bell
Creative Design Studios

Support forums: https://forums.chrisbelldesigns.com/

Dave215
Posts: 14
Joined: Thu Nov 01, 2012 9:37 am

Re: v3.1 severe memory leak!

Postby Dave215 » Sat Jan 02, 2016 8:36 am

How can i fix this leak?
Is it possible?
Hope there is an update soon!

Saul
Posts: 3510
Joined: Mon Mar 04, 2013 1:02 pm
Location: Manchester, UK

Re: v3.1 severe memory leak!

Postby Saul » Sat Jan 02, 2016 8:56 am

Hi Chris,

I don't think this my suggestion will have any effect on your findings as it seems a totally different issue yet again...
Rob and I stumbled upon a phenomena that when HT is enabled in the BIOS extra memory is consumed.

Glad we got those night textures sorted finally :D is it completely fixed now ? or just much better?

Happy New Year ;)

Wills
Posts: 207
Joined: Fri Dec 20, 2013 5:36 pm

Re: v3.1 severe memory leak!

Postby Wills » Sat Jan 02, 2016 9:01 am

Dave, we have to wait for LM to release a software patch to fix this leak. We just have to hang tight.

Wills
Posts: 207
Joined: Fri Dec 20, 2013 5:36 pm

Re: v3.1 severe memory leak!

Postby Wills » Sat Jan 02, 2016 9:02 am

Saul, Hyperthreading off does not help here. I run with HT off in the UEFI and I suffer from this issue too.

sbs9
Posts: 46
Joined: Sat Oct 17, 2015 11:28 am

Re: v3.1 severe memory leak!

Postby sbs9 » Sat Jan 02, 2016 9:32 am

Wills wrote:Saul, Hyperthreading off does not help here. I run with HT off in the UEFI and I suffer from this issue too.

+1

Night Environment worked flawlessly in v3.0, it is a conditio sine qua non for night training scenarios. Frankly, I am surprised, 3.1 was released without testing compatibility with such an essential add-on.

egkkman
Posts: 62
Joined: Tue Oct 08, 2013 5:39 am

Re: v3.1 severe memory leak!

Postby egkkman » Sat Jan 02, 2016 12:09 pm

Hi Wills,

Yes agreed, we have to wait.

Happy to help LM where possible with tests etc.

Regards

Dave

User avatar
MyPC8MyBrain
Posts: 660
Joined: Sat Apr 06, 2013 4:05 pm
Location: Los Angeles, CA
Contact:

Re: v3.1 severe memory leak!

Postby MyPC8MyBrain » Sat Jan 02, 2016 2:55 pm

Saul James wrote:Hi Chris,

I don't think this my suggestion will have any effect on your findings as it seems a totally different issue yet again...
Rob and I stumbled upon a phenomena that when HT is enabled in the BIOS extra memory is consumed.

Glad we got those night textures sorted finally :D is it completely fixed now ? or just much better?

Happy New Year ;)


Happy New Year Saul,
and Happy new year to all LM supporting and developing branches :)

the new colors in 3.1 looks fantastic! (tad still on the orange side imo);
but no doubt 3.1 completely changes the night ambiance 10 folds over 3.0; or any previous version!
the overall feel is much much closer to the intended colors; i actually love the HDR effect with Tess now!
before they were not complimenting the night environment; but now... LOVE IT!

i had little time to enjoy the new colors; as i been chasing this little bug around;
i had several issues (unrelated) that confused me at first from zooming in the issue;
this little bug is clouding the great job you guys did with 3.1,

i was hoping its something like the HT issue or something in those lines;
the guys over at our support portal helped out throughout; helping with testing and trying to cross reference to eliminate variables;
none seem to have rectified the issues in any satisfactory way so far,
http://forums.nightenvironment.com/topi ... version-31

i even went ahead and recompiled the "offending" bgl's with the latest 3.1 SDK bglcomp;
still getting exactly the same behavior in 3.1 when accessing xml library objects compiled via bglcomp;
the file output from the latest bglcomp is identical! both older files and new file i rendered are behaving the same way,
under v3.0 the same exact files perform as expected (added image from 3.0 for comparison)

i suspect this issue will be far less noticeable with just a handful of objects;
in my case the abundance of them seem to bring 3.1 to a halt
Last edited by MyPC8MyBrain on Sat Jan 02, 2016 2:59 pm, edited 1 time in total.
Chris Bell
Creative Design Studios

Support forums: https://forums.chrisbelldesigns.com/

User avatar
MyPC8MyBrain
Posts: 660
Joined: Sat Apr 06, 2013 4:05 pm
Location: Los Angeles, CA
Contact:

Re: v3.1 severe memory leak!

Postby MyPC8MyBrain » Tue Jan 05, 2016 7:19 pm

to make this even more interesting of a leak;
same region will load with no delays in some areas; while stalling in others,

(im sorry if i haven't mentioned this before;
any of my title LM wish to have for testing from our line you guys are welcome to!)

Regards,
Chris
Chris Bell
Creative Design Studios

Support forums: https://forums.chrisbelldesigns.com/

Darren Goldfarb
Posts: 62
Joined: Wed May 23, 2012 2:12 pm

Re: v3.1 severe memory leak!

Postby Darren Goldfarb » Tue Jan 12, 2016 6:31 pm

Hi Chris,

We tracked down what was causing this issue and it has been resolved. The fix will make it into our next release.

Regards,

Darren

Airwolf
Posts: 105
Joined: Sun Dec 09, 2012 7:48 pm

Re: v3.1 severe memory leak!

Postby Airwolf » Tue Jan 12, 2016 7:13 pm

Chris - Thank you for finding this bug

Darren and Saul - Super excited to see this fix applied whenever the release is out.

P3Dv3 just keeps on getting better.

Wills
Posts: 207
Joined: Fri Dec 20, 2013 5:36 pm

Re: v3.1 severe memory leak!

Postby Wills » Tue Jan 12, 2016 8:30 pm

Thanks for the great news Darren :D!

egkkman
Posts: 62
Joined: Tue Oct 08, 2013 5:39 am

Re: v3.1 severe memory leak!

Postby egkkman » Tue Jan 12, 2016 8:45 pm

Great news Darren,

Thanks to the LM team for hunting this down.

Regards

Dave

User avatar
MyPC8MyBrain
Posts: 660
Joined: Sat Apr 06, 2013 4:05 pm
Location: Los Angeles, CA
Contact:

Re: v3.1 severe memory leak!

Postby MyPC8MyBrain » Tue Jan 12, 2016 10:18 pm

Bravo guys,
a personal thank you to Darren, Adam, and Saul for their help and support with this bug,
Thank you so much for this superb support response!!! FANTASTIC guys,

did i already say, I LOVE LM! :)
Chris Bell
Creative Design Studios

Support forums: https://forums.chrisbelldesigns.com/

gordonhutchison
Posts: 31
Joined: Sun Nov 17, 2013 1:32 pm

Re: v3.1 severe memory leak!

Postby gordonhutchison » Tue Jan 12, 2016 10:41 pm

Well done guys, great customer support from LM on this one!

Cheers!


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: No registered users and 27 guests