dxgi error device removed...

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
pracines
Posts: 122
Joined: Mon Nov 25, 2013 4:01 am

Re: dxgi error device removed...

Postby pracines » Thu Sep 06, 2018 12:27 am


I wanted to test the sim in its default state so that LM can't pass the blame onto others. On many of their replies on other posts they refer people to a general debugging url with the usual questions about having an up date OS and drivers and then discuss what add-ons you are running. If the sim crashes with no add-ons installed then the problem more than likely is the sim. You maybe right about shadows, my crashes occur mostly and dusk or night time. Ive never tried a flight with shadows all switched off...wouldnt want to have the sim without them anyhow though to debug maybe worth a test.

Chris
I agree with what you are doing, but I hate that you have to.

At first I thought my GTX 980 was not up to the task, but when I saw 1080ti's with the same error, I thought not again, not another plague like OOM to destroy.

64 bit came so we could raise the sliders, but here we are again. (I realize not everybody has this issue currently)

I personally push the limits settings wise and lock frames at 20. I also likely fly much more often then most others usually have the sim running constantly depending on flight lengths, etc. Currently flying PMDG 777LR from EGLL (Aerosoft) to YMML (Orbx) and almost 9 hours in its all smooth and pegged at 20. But the fact that I/we have to be concerned about this DXGI bologna ever since version 4.3 (note that the first post here was 4 days after 4.3 was released and NVidia gets blamed w/o doubts or questions), reminds me of OOM all over again.

For me lowering the sliders prevents this error (specifically tessellation, shadow distance, and auto gen distance). I always use the latest graphics driver, so to me this is not specifically a graphics driver issue.

The only wild guess I have is that P3D is asking the grahics engine something the wrong way or mixing too much old with new tech. Performance wise 4.3 is very excellent, but it may be achieving this excellent performance with some method that compels the sys to call foul......again a wild guess from one w/o knowledge of such details.

I dont want to do this but I'm going to have to pray that some P3D users who are PC gurus or Elaine or other LM staff get this error because, I can see it now, version 4.4 comes out and everybody gets the error all the time. Thats how it happend with OOM - a few (myself included) were getting OOM's then eventually a runaway plague.
Win 10 64bit | Z97 Pro | i7 4790 4.6GHz | Corsair Hydro Series H80i GT Liquid Cooling |
16GB RAM | GTX 980 | Oculus Rift | 1TB Samsung EVO 850 SSD | 2TB WD Black 7200 RPM SATA 6.0Gb/s

Martyson
Posts: 5848
Joined: Sun Mar 25, 2012 11:08 am

Re: dxgi error device removed...

Postby Martyson » Thu Sep 06, 2018 6:08 am

"But the fact that I/we have to be concerned about this DXGI bologna ever since version 4.3 (note that the first post here was 4 days after 4.3 was released and NVidia gets blamed w/o doubts or questions), reminds me of OOM all over again. "

I have not seen this DXGI error with P3Dv4.3 or any previous P3D version while using e.g., Nvidia GTX960, PMDG737/777, VRS F18E, other payware aircraft, ActiveSky, FSDT/FlightBeam/Orbx scenery with Win7-64.

I do not do long hauls e.g., while actually sleeping for 8 hours with the sim set to pause at TOD.

I also do not use the PC to do any other tasks like spreadsheets, taxes, word processing, on-line searches, watching videos, posting in forums etc. during a flight.

My PC is a couple years old and I have used many Nvidia drivers (always driver only and clean install, no other Nvidia options selected) e.g.:
388.71
390.77
391.24
391.35
387.64
397.93
398.11
398.36
398.82
399.07 8-31-18 P3Dv4.3 and other Sims (currently no problems to report).

As far as P3D options/sliders I never max out any thing and lock FPS at 20.
The exception is e.g. when a developer like Orbx recommends a max setting then I test it and decide what is best for my setup.

But, the sliders and Options need to be set on a per system basis for best error free performance.
Best Regards,
Vaughan Martell (KDTW)

cjibbotson
Posts: 33
Joined: Mon May 14, 2012 7:13 pm

Re: dxgi error device removed...

Postby cjibbotson » Thu Sep 06, 2018 8:30 am

[/quote]

I personally push the limits settings wise and lock frames at 20. I also likely fly much more often then most others usually have the sim running constantly depending on flight lengths, etc. Currently flying PMDG 777LR from EGLL (Aerosoft) to YMML (Orbx) and almost 9 hours in its all smooth and pegged at 20. But the fact that I/we have to be concerned about this DXGI bologna ever since version 4.3 (note that the first post here was 4 days after 4.3 was released and NVidia gets blamed w/o doubts or questions), reminds me of OOM all over again.

For me lowering the sliders prevents this error (specifically tessellation, shadow distance, and auto gen distance). I always use the latest graphics driver, so to me this is not specifically a graphics driver issue.

The only wild guess I have is that P3D is asking the grahics engine something the wrong way or mixing too much old with new tech. Performance wise 4.3 is very excellent, but it may be achieving this excellent performance with some method that compels the sys to call foul......again a wild guess from one w/o knowledge of such details.

[/quote]

DXGI errors have been appearing in P3D for almost 2 years though have seriously escallated over the past few months. After ruling out Windows by doing fresh installs of older builds or even using W8.1 and old drivers I have ruled both them out as triggering the crashes because up to earlier this year I never got those crashes. I myself started to wonder was it the 4.3 update causing me problems as the date I downloaded the file was roughly when I remember having crashes from. The DXGI crashes could take many hours to happen and as I generally just do short flights I cant be certain the problem wasn't always there. I did uninstal the 4.3 Client and install 4.2 but still got crashes. I appreciate I should have removed the whole sim but due to all these tests and formats Ive had to request my activations limit be reset a couple of times so Im concious LM may start refusing.

Ive had crashes on default settings so zero stress on the gpu at all.

I just dont get why Lockheed Martin refuse to comment. This is their support forum isn't it?? :(

Chris

TomazDrnovsek
Posts: 120
Joined: Mon Jul 02, 2012 3:01 pm

Re: dxgi error device removed...

Postby TomazDrnovsek » Thu Sep 06, 2018 10:18 am

But, the sliders and Options need to be set on a per system basis for best error free performance.
That's a new one. I didn't know that wrongly set sliders can produce application errors.

shermank
Posts: 42
Joined: Thu Nov 28, 2013 6:17 pm

Re: dxgi error device removed...

Postby shermank » Thu Sep 06, 2018 3:02 pm

I also rolled back to 397 for the same reasons cited above by other posters. Things have run well since then...btw, I did not do a clean install, but now that the suggestion has been made, I will reinstall clean.....


Sherm

B77X
Posts: 41
Joined: Mon Jun 05, 2017 6:00 pm

Re: dxgi error device removed...

Postby B77X » Sat Sep 29, 2018 12:11 am

If you have this error is vsync enabled in p3d menu options?

KevinKaessmann
Posts: 33
Joined: Sat Aug 04, 2018 10:14 am

Re: dxgi error device removed...

Postby KevinKaessmann » Sat Sep 29, 2018 10:57 pm

As I stated before, this error could result from Windows TDR, see here:
https://support.microsoft.com/en-us/hel ... -windows-7 - Method 3

So why not give a chance to add this registry value:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\TdrDelay
(Windows 64bit as REG_QWORD) and set it to a value of 10...15 (seconds waiting for GPU command execution)

https://imgur.com/a/ycit35L

The Windows TDR Checker runs not only in Win 7 but also in Win 10:
https://answers.microsoft.com/en-us/win ... 2d32d4dbe2

B77X
Posts: 41
Joined: Mon Jun 05, 2017 6:00 pm

Re: dxgi error device removed...

Postby B77X » Sun Sep 30, 2018 2:58 am

As I stated before, this error could result from Windows TDR, see here:
https://support.microsoft.com/en-us/hel ... -windows-7 - Method 3

So why not give a chance to add this registry value:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\TdrDelay
(Windows 64bit as REG_QWORD) and set it to a value of 10...15 (seconds waiting for GPU command execution)

https://imgur.com/a/ycit35L

The Windows TDR Checker runs not only in Win 7 but also in Win 10:
https://answers.microsoft.com/en-us/win ... 2d32d4dbe2
I setup that registry entry for this P3D user on the latest Nvidia drivers. It was either vsync or scenery from NXGN Nadi / Tahiti scenery. Both NXGN scenery removed and vsync unchecked 11 hours no crash currently. Enabling vsync and activating the 2 sceneries to the library after 6 hours they had the Device Hung message. Previously a month and more without that error.

Alexis_67
Posts: 18
Joined: Tue Dec 27, 2016 2:20 pm

Re: dxgi error device removed...

Postby Alexis_67 » Sun Sep 30, 2018 8:28 am

Hello All,

I return to this post after several months without news. For a moment I had more had this error.

This morning I made a flight of SAEZ for FACT with the PMDG 747-8F. At the end of 7 hours, surprised, I received this error, My flight was save, I was able to load it and finish it.

I did not use Nvidia Inspector, No modification of CFG, No scenery, I just have ORBX and AS16.

My version of the graphics driver is 399.24 , I will surely update it : 411.70.

I think this mistake really comes at random..

( Sorry for my bad english, i use google translat. )
CPU: Intel i7-4790k @4.6Ghz | GPU: MSI GTX1070Ti | MoBo: MSI Z97 Gaming 5 | OS: Win10 64bit 1809 | RAM: Corsair 2X8GB DDR3 1886Mhz | HD: 2.3TB | SSD: Samsung 850Pro 256Go ( Système + P3D ) | Sims: P3D V4.4 |

B77X
Posts: 41
Joined: Mon Jun 05, 2017 6:00 pm

Re: dxgi error device removed...

Postby B77X » Sun Sep 30, 2018 5:15 pm

Hello All,

I return to this post after several months without news. For a moment I had more had this error.

This morning I made a flight of SAEZ for FACT with the PMDG 747-8F. At the end of 7 hours, surprised, I received this error, My flight was save, I was able to load it and finish it.

I did not use Nvidia Inspector, No modification of CFG, No scenery, I just have ORBX and AS16.

My version of the graphics driver is 399.24 , I will surely update it : 411.70.

I think this mistake really comes at random..

( Sorry for my bad english, i use google translat. )
Do you have vsync enabled in the p3d options?

Alexis_67
Posts: 18
Joined: Tue Dec 27, 2016 2:20 pm

Re: dxgi error device removed...

Postby Alexis_67 » Mon Oct 01, 2018 5:41 am

Hello All,

I return to this post after several months without news. For a moment I had more had this error.

This morning I made a flight of SAEZ for FACT with the PMDG 747-8F. At the end of 7 hours, surprised, I received this error, My flight was save, I was able to load it and finish it.

I did not use Nvidia Inspector, No modification of CFG, No scenery, I just have ORBX and AS16.

My version of the graphics driver is 399.24 , I will surely update it : 411.70.

I think this mistake really comes at random..

( Sorry for my bad english, i use google translat. )
Do you have vsync enabled in the p3d options?
Hello,

The flight from SAEZ to FACT was with the V-Sync activated, this morning I prepared another flight, this time without V-Sync and even without the V-Sync I had this error after 20 minutes. I strongly hesitate to any formatted ...
CPU: Intel i7-4790k @4.6Ghz | GPU: MSI GTX1070Ti | MoBo: MSI Z97 Gaming 5 | OS: Win10 64bit 1809 | RAM: Corsair 2X8GB DDR3 1886Mhz | HD: 2.3TB | SSD: Samsung 850Pro 256Go ( Système + P3D ) | Sims: P3D V4.4 |

Sputz
Posts: 3
Joined: Tue Nov 28, 2017 5:27 am

Re: dxgi error device removed...

Postby Sputz » Tue Oct 02, 2018 1:43 am

I am following this with great interest (and frustration). Since upgrading my GPU to a Asus ROG STRIX 1080Ti (4 weeks ago), I have had this devastating problem also. Everything was fine when I was using my R9 380X.
This would tend to indicate the NVIDIA drivers which some have suggested. (The only way I can check that is to go back to my AMD GPU, which is not convenient at this time).
I too have tried a number of archived drivers on clean install, with no change. I have also tried the TRD approach including TrdDelay as well as TrdLevel), found it worse using QWord (for my W10 64bit OS) than DWord. I have also tried a number of the other "solutions" as suggested by helpful members, but, as with Alexis_67, nothing I have tried is SOLVING the problem. The timing for it to occur is so random that sometimes I think it is fixed, but a few minutes more and BANG!
Add my name to an urgent appeal to LM to get involved in solving this problem as I too am just about to throw P3D away and try X-Plane (I haven't seen any reports about this from them, have you?). Maybe it's not a P3D problem, but maybe it is.

Alexis_67
Posts: 18
Joined: Tue Dec 27, 2016 2:20 pm

Re: dxgi error device removed...

Postby Alexis_67 » Tue Oct 02, 2018 4:47 am

I feel that I will be returned on Windows XP and Fs2004 !
CPU: Intel i7-4790k @4.6Ghz | GPU: MSI GTX1070Ti | MoBo: MSI Z97 Gaming 5 | OS: Win10 64bit 1809 | RAM: Corsair 2X8GB DDR3 1886Mhz | HD: 2.3TB | SSD: Samsung 850Pro 256Go ( Système + P3D ) | Sims: P3D V4.4 |

B77X
Posts: 41
Joined: Mon Jun 05, 2017 6:00 pm

Re: dxgi error device removed...

Postby B77X » Wed Oct 03, 2018 4:40 am

Hello All,

I return to this post after several months without news. For a moment I had more had this error.

This morning I made a flight of SAEZ for FACT with the PMDG 747-8F. At the end of 7 hours, surprised, I received this error, My flight was save, I was able to load it and finish it.

I did not use Nvidia Inspector, No modification of CFG, No scenery, I just have ORBX and AS16.

My version of the graphics driver is 399.24 , I will surely update it : 411.70.

I think this mistake really comes at random..

( Sorry for my bad english, i use google translat. )
Do you have vsync enabled in the p3d options?
Hello,

The flight from SAEZ to FACT was with the V-Sync activated, this morning I prepared another flight, this time without V-Sync and even without the V-Sync I had this error after 20 minutes. I strongly hesitate to any formatted ...
what is the Orbx scenery you use? Do you run p3d as administrator? have you installed Nvidia drivers using displaydriveruninstaller and a clean install? Have you tried a clean install of prepar3d?

Alexis_67
Posts: 18
Joined: Tue Dec 27, 2016 2:20 pm

Re: dxgi error device removed...

Postby Alexis_67 » Wed Oct 03, 2018 4:54 pm

what is the Orbx scenery you use? Do you run p3d as administrator? have you installed Nvidia drivers using displaydriveruninstaller and a clean install? Have you tried a clean install of prepar3d?
Hello ,

- I still run P3D as administrator.
- I used DDU for a new Nvidia driver about 1 month ago.
- I uninstall and reinstall P3D before yesterday.

I flew a flight of 5 hours this morning, no problem.

My addon list :

- FTX Global BASE Pack
- Hifi AS16
- GSX
- EZDOK
- PMDG 737/747

I am waiting for several flights before confirming that everything works.
CPU: Intel i7-4790k @4.6Ghz | GPU: MSI GTX1070Ti | MoBo: MSI Z97 Gaming 5 | OS: Win10 64bit 1809 | RAM: Corsair 2X8GB DDR3 1886Mhz | HD: 2.3TB | SSD: Samsung 850Pro 256Go ( Système + P3D ) | Sims: P3D V4.4 |


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 11 guests