Shared Cockpit - Spontaneous Time Acceleration

Any issues, problems or troubleshooting topics related to the Prepar3D client application's multiplayer mode
dmstumpf
Posts: 3
Joined: Sat Dec 07, 2013 5:31 pm

Postby dmstumpf » Wed Jan 15, 2014 7:47 pm

My copilot and I have encountered a problem where time will suddenly accelerate from 1x to approximately 2x during a multiplayer shared cockpit session. The session starts normally, and at some point during the session the time rate will increase. Here are our symptoms:



* Occurs at some seemingly random point during the flight - on the ramp, after takeoff, or during landing

* Time rate will suddenly accelerate

* All instruments/gauges appear normal

* Aircraft races across terrain

* Cockpit clock advances at a high rate

* Time of day advances at a high rate



Here's what we know about the issue so far:



* It has only occurred when the guest/secondary pilot is in control

* Happens with multiple aircraft



As we know, time acceleration is disabled in multiplayer sessions, so it's a mystery how this is happening and, worse, it cannot be stopped.

JoeK
Posts: 6
Joined: Fri Jan 10, 2014 2:25 pm

Postby JoeK » Fri Jan 17, 2014 11:10 am

Thank you, Danny. We'll take a look into this issue.

FSMP
Posts: 678
Joined: Sat Sep 25, 2010 9:38 am

Postby FSMP » Fri Jan 17, 2014 11:29 am

FYI:



The "suddenly accelerate from 1x to approximately 2x (OR MORE) during a multiplayer shared cockpit" was an INITIAL bug in FSX during development, and was reported by the beta team.



It was "FIXED" by Microsoft during beta, but the only reason so the bug, released to the beta team, was that it was some form of "TIMING RACE CONDITION", and there was no further information released to the beta team as to what had caused it, or how it was fixed.



After it was "FIXED" in FSX beta, it was never reported again as happening. I also do not believe it happened in P3D 1.x. Grated, there has only been far less P3D "Shared Cockpit" hours than FSX "Shared Cockpit" hours, but I do not recall ever seeing anyone bring it up as being an issue in P3D 1.x



If this problem is confirmed in P3D 2.x, and then gets fixed, I would be most interested to know what caused it, and how it gets fixed... the mechanism of this has been BUGGING me for years !! ( excuse the Pun)




Tailhook
Posts: 4
Joined: Fri Dec 26, 2014 7:49 am

Postby Tailhook » Fri Dec 26, 2014 2:52 am

I can confirm this bug still happens with P3D v2.4. It's happened twice now with myself and a friend sharing the Carenado Phenom 100.

ldtaylor
Posts: 7
Joined: Thu Jul 18, 2013 6:08 pm

Postby ldtaylor » Mon Mar 23, 2015 12:47 pm

I can also confirm this bug in v2.4. Multiplayer flying the C172 w/Mindstar G1000. One system Win 7 the other Win 8.1.

beenster99
Posts: 2
Joined: Tue Oct 14, 2014 10:30 pm

Postby beenster99 » Mon Jul 06, 2015 8:11 am

I can confirm that this problem still exists under the following conditions:

Shared cockpit flying of any stock aircraft in Prepar3D v2 (Academic Version). Windows 7 and Windows 8 clients. It always happens after an exchange of cockpit controls and seems to be reasonably random in terms of when it happens. It is irreversible even if control is returned to the session host. It happens when either of us acts as host.

It happens EVERY time. Please return with an update or some information if there is a workaround. Many thanks.
Simon

Tailhook
Posts: 4
Joined: Fri Dec 26, 2014 7:49 am

Postby Tailhook » Mon Jul 06, 2015 5:20 pm

Just curious, to everyone who has been having this problem, do you have FSUIPC installed on the host system?

ldtaylor
Posts: 7
Joined: Thu Jul 18, 2013 6:08 pm

Postby ldtaylor » Mon Jul 06, 2015 6:27 pm

Yes, v4.939k.

beenster99
Posts: 2
Joined: Tue Oct 14, 2014 10:30 pm

Postby beenster99 » Tue Jul 07, 2015 6:02 am

Yes, also v4.939

deltafan
Posts: 14
Joined: Mon Aug 27, 2012 3:12 pm

Re: Shared Cockpit - Spontaneous Time Acceleration

Postby deltafan » Sat Nov 07, 2015 6:42 pm

It appears this problem still exists in Prepar3D V3. I just got done with a multiplayer session in P3D v3 where this occurred during shared cockpit. Hope it can be resolved.

Jordi
Posts: 1
Joined: Mon Aug 20, 2012 4:41 pm

Re: Shared Cockpit - Spontaneous Time Acceleration

Postby Jordi » Sat Nov 07, 2015 8:29 pm

Yes can also confirm its happening to me. Others I speak to have reported the same thing with almost every session.

ldtaylor
Posts: 7
Joined: Thu Jul 18, 2013 6:08 pm

Re: Shared Cockpit - Spontaneous Time Acceleration

Postby ldtaylor » Wed Dec 09, 2015 7:53 pm

This is becoming a big issue. I had to stop my last multiplayer session with my instructor due to this problem. Practicing instrument approaches is almost impossible! This issue was first reported in January 2014. Joek said "I'll look into it" right after the first report. Last report is November 2015 stating that it occurs in v3. I just don't get it. The problem still exits but no fixes, no workarounds, no multitudes of new reports, no suggestions from anybody. This must be an isolated problem since there isn't a huge outcry from users. Is there a common configuration causing this problem with these users? Does anybody have any suggestions? We are about to abandon P3D! This is a great simulation, but . . . this sucks. Please help . . . somebody!

Clifton Crane
Lockheed Martin
Posts: 997
Joined: Tue Sep 25, 2012 2:34 pm

Re: Shared Cockpit - Spontaneous Time Acceleration

Postby Clifton Crane » Thu Dec 10, 2015 8:27 pm

Hello,

We have attempted to reproduce this issue but have been unable to. It seems to be an isolated issue as not many users are reporting this issue. Can you confirm that both clients are using the same version of Prepar3D?

Additionally, can you provide more information on your setup including any add-ons installed, operating system, shared cockpit vehicle, structured or standard scenario, etc?

Also, is this issue repeatable? Can you provide steps to repeat it if so? Does it happen every time you transfer control?
Clifton Crane
Prepar3D® Software Engineer Sr.

ldtaylor
Posts: 7
Joined: Thu Jul 18, 2013 6:08 pm

Re: Shared Cockpit - Spontaneous Time Acceleration

Postby ldtaylor » Wed Dec 16, 2015 4:43 pm

I believe we have found the source of our Spontaneous Time Acceleration (STA) problem, plus I think we found an additional problem.
We both did a fresh install of v3. Left everything set at defaults. Flew from KAPA to KBJC in the Mooney Acclaim with G1000 4. When we loaded the ILS 29R procedure then "activated", we got a "Fatal Error" message for the Host. We changed to the Mooney Bravo with G1000 with the same results. The STA problem did not occur.
We then added FSXFlight app and the required FSUIPC4 v4.948e add-on to both PCs. We both use ForeFlight on iPads so this is an important app when running simulations. The STA problem reappeared! We then removed FSUIPC4 and the STA problem went away.
To answer your questions:
1. We are both using the same version, now v3.
2. Both PCs are identical except for the graphics cards GTX970 & GTX 570 (I previously posted details of both systems but looks like it was deleted for some reason.)
3. Neither installation had any add-ons expect as noted above.
4. Same aircraft, standard scenario, same flight plan, location, graphics profiles, etc.
5. Windows 10 same version with most recent updates. Same for all ASUS drivers, NVidia, etc.
6. The steps to repeat the problem are noted above.
Any suggestions beside not using FSUIPC4 and FSXFlight? Let me know if you need any more information. Thanks for your help.

FSMP
Posts: 678
Joined: Sat Sep 25, 2010 9:38 am

Re: Shared Cockpit - Spontaneous Time Acceleration

Postby FSMP » Thu Dec 17, 2015 1:03 am

I am watching this thread with interest.

As the OP is able to reproduce the Spontaneous Time Acceleration with some degree of reputability, when they have installed both FSXFlight app and the required FSUIPC4 v4.948e, maybe they could test again with just FSUIPC, to help narrow down what product is causing the issue.


Return to “Multiplayer Specific Questions”

Who is online

Users browsing this forum: No registered users and 8 guests