Losing Peripheral Devices when Hosting Multiplayer

Any issues, problems or troubleshooting topics related to the Prepar3D client application's multiplayer mode
AO1986
Posts: 17
Joined: Thu Mar 16, 2017 2:04 pm

Losing Peripheral Devices when Hosting Multiplayer

Postby AO1986 » Thu Mar 16, 2017 3:39 pm

I am hosting a multiplayer session and continually lose functionality of my Logitech extreme 3D joystick as well as my Saitek Rudder Pedals. Individuals are able to connect just fine to my session. However, 1-2 minutes into flight, I lose all responsiveness in my controls. I have tested this with users connected to the session, as well as just starting up a session without anyone connected. Same issues arise. All controls are lost. I can be in flight for 2 minutes and lose all input control. I can be simply sitting on the runway and as several minutes pass, controls are lost.

I have searched on the forum for any fixes. I see multiple users having similar issues Other keyboard buttons work when my joystick and rudder pedal input are lost. When I activate the menu and click on Settings to troubleshoot my joystick assignments or to disable and reenable controls Prepar3d crashes. I am unable to even get into the settings menu. This is only when I am in multiplayer. Flying alone without multiplayer I have no issues at all. I have also read about Enabling Direct Input Control (Direct Input API). I did that and still, the same problem.

Among the posts I have read, there haven't been any fixable solutions I have come across. Any help would be great! Thank you in advance!

Aaron

Clifton Crane
Lockheed Martin
Posts: 763
Joined: Tue Sep 25, 2012 2:34 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby Clifton Crane » Thu Mar 16, 2017 10:13 pm

Hello,

A few questions:
  1. Are you in a shared cockpit session?
  2. If you unplug the device and plug it back in, do controls start to work again?
  3. Are you sure joystick controls were not accidentally disabled using the Ctrl+K shortcut? This is the default key binding.
Thanks.
Clifton Crane
Prepar3D® Software Engineer

AO1986
Posts: 17
Joined: Thu Mar 16, 2017 2:04 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby AO1986 » Thu Mar 16, 2017 11:01 pm

Hi Clifton,

I can confirm that the answer to all three is No. I have troubleshooter each step.

Any other thoughts?

Clifton Crane
Lockheed Martin
Posts: 763
Joined: Tue Sep 25, 2012 2:34 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby Clifton Crane » Thu Mar 16, 2017 11:06 pm

Do the devices correctly show in the Windows Control Panel under the Devices and Printers section at the time of the issue?
Clifton Crane
Prepar3D® Software Engineer

AO1986
Posts: 17
Joined: Thu Mar 16, 2017 2:04 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby AO1986 » Thu Mar 16, 2017 11:14 pm

Yes they do. I have also reinstalled each driver. It appears based on multiple threads, it is a problem among several users as well.

User avatar
aeronauta
Posts: 1280
Joined: Sun Oct 23, 2011 1:56 am
Location: Melbourne, Australia

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby aeronauta » Fri Mar 17, 2017 7:01 am

Hi , can I suggest that you remove all drivers and let Windows install your devices (dont use any drivers) , then try..
Jorge
Jorge Roldan
OZx Developer (aero) - Hovercontrol Helicopter Certified Pilot - Spad.Next Beta Tester

AO1986
Posts: 17
Joined: Thu Mar 16, 2017 2:04 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby AO1986 » Fri Mar 17, 2017 2:03 pm

Thank you for your response Jorge. When I installed the drivers that is what I did. I let windows install the necessary drivers for my Logitech Extreme 3D Pro as well as my Saitek Rudder Pedals.

AO1986
Posts: 17
Joined: Thu Mar 16, 2017 2:04 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby AO1986 » Sun Mar 19, 2017 9:13 pm

Tried a multiplayer session without anyone connected and all peripherals 2 minutes into flight again. I tried to look through my content error log for prepar3d but only found the items below. After I lose control over the devices, I try to open up settings which crashes Prepar3d. Under reliability history, the crash does not show up, so I am unable to see a faulting module.

Any ideas send my way :)

Thanks!

Aaron


[error.0]
error=Found Duplicate Key Name
File:D:\Prepar3D\SimObjects\Airplanes\FTX NA Beechcraft King Air A100\aircraft.cfg
Section:autopilot
Key:max_throttle_rate

[error.1]
error=Duplicate Section Name
File: D:\Prepar3D\SimObjects\Airplanes\FTX NA Challenger CL-604\aircraft.cfg
Section: EFFECTS

[error.2]
error=Found Duplicate Key Name
File:D:\Prepar3D\SimObjects\Airplanes\FTX NA Learjet 35\aircraft.cfg
Section:fltsim.7
Key:description

[error.3]
error=Found Duplicate Key Name
File:D:\Prepar3D\SimObjects\Airplanes\FTX NA Learjet 35\aircraft.cfg
Section:fltsim.8
Key:description

[error.4]
error=Found Duplicate Key Name
File:D:\Prepar3D\SimObjects\Airplanes\FTX NA Learjet 35\aircraft.cfg
Section:fltsim.9
Key:description

[error.5]
error=Duplicate Section Name
File: D:\Prepar3D\SimObjects\Airplanes\FTX NA Piper Navajo\aircraft.cfg
Section: GeneralEngineData

Pricetx
Posts: 8
Joined: Mon Apr 02, 2012 7:37 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby Pricetx » Tue Mar 28, 2017 6:59 pm

I just thought i'd chime in and say that I'm also facing precisely this problem. It seems regardless of the scenario I configure for, after a few minutes of being a session host I lose all input from both my CH Yoke and CH Pedals. Additionally, once this has happened, loading a menu (such as the world map) causes Prepar3D to lock up and crash.

I am running version 3.4.22.19868. If you would like any further system info or logs, please let me know. If I get time later I might get back to this and see if I can find any further details on the issue.

Pricetx
Posts: 8
Joined: Mon Apr 02, 2012 7:37 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby Pricetx » Tue Mar 28, 2017 8:25 pm

As per this thread http://www.prepar3d.com/forum/viewtopic ... 64#p148564 I appear to have resolved the issue for myself.

Switching from Raw Input to DirectInput stopped the controls from locking up, and it also seemed to resolve my issue with opening menus causing the application to crash (although the latter may require further testing to make sure I wasn't just lucky on one occasion).

Finally, I was able to exit multiplayer after 10+ minutes without the application crashing, which other people seem to have had issues with.

AO1986
Posts: 17
Joined: Thu Mar 16, 2017 2:04 pm

Re: Losing Peripheral Devices when Hosting Multiplayer

Postby AO1986 » Tue Mar 28, 2017 9:28 pm

Thanks for the response. Unfortunately I have already tried that with no luck. Glad it worked for you!!


Return to “Multiplayer Specific Questions”

Who is online

Users browsing this forum: No registered users and 1 guest