Frequently loosing the joystick

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
taylordude
Posts: 4
Joined: Mon Nov 25, 2013 9:46 pm

Postby taylordude » Mon Jan 13, 2014 6:28 pm

Same issue with Win7 64 bit Attack 3 logitech.. My rudder just locks up full left, oddly while trying to troubleshoot it just starting working out of the blue. So I went with it and decided to change one of my button assignments and now the problem is back with a new twist, when I load the Cernado Commander 114 it will control taxi and takeoff but not the ailerons, but I see them working when using external views. Very frustrating.

jmejia
Posts: 3
Joined: Thu Nov 28, 2013 1:35 am

Postby jmejia » Thu Jan 16, 2014 6:44 pm

I've got the same issue. someone mentioned changing the " power management" settings in windows 8/8.1 but that has not worked. I still loose controllers at random sometimes, and every time I change aircraft. I'd beg to differ that this is not a P3D issue, since FSX and Xplane run flawlessly for hrs even with alt tabing out to different tasks.



OS - was W8 is now W8.1



controllers lost: cessna yoke, trim, throttle, rudder pedals.



-J

whiskylima
Posts: 21
Joined: Tue Nov 15, 2011 6:16 pm

Postby whiskylima » Sat Jan 18, 2014 11:08 am

I am having similar problems in the last day or so. I have been using Prepar3d v2.0 since release using a mixture of CH and Saitek products without an issue but am now having difficulty assigning controls to axis, for example I can set up a yoke but when I try to set up the rudder pedals, they are conflicting with the yoke. I am puzzled as to why this has only recently started giving problems as it has been fine till now and I thought I was reasonably familiar with setting up peripherals. I am using Windows 7 64 bit. Any suggestions would be appreciated.

cannow
Posts: 75
Joined: Mon Nov 25, 2013 5:51 pm

Postby cannow » Sun Jan 19, 2014 5:41 am

Hope Lockheed Martin can sort this one out. Can not use P3d at moment because of the constant loss of joystick by placing the uicoreautomation.dll in the root of p3d has improved but still cannot finish a flight. Allways occurs on lack of focus ie clicking on plang mid flight.Fault occurs on fsx as well but no way near as often. Appreciate a window fault with win8 might have to bite the bullitt and pay for FSUIPC if does not make it in to the next patch.

Rolfspan
Posts: 29
Joined: Wed Sep 28, 2011 10:07 pm

Postby Rolfspan » Sun Jan 19, 2014 10:39 am

Similar problems with Saitek X-65F. Tried different ways of calibrating but no success. All seems fine in FSX. Running windows 7.

jmejia
Posts: 3
Joined: Thu Nov 28, 2013 1:35 am

Postby jmejia » Sun Jan 26, 2014 2:47 am

-Update



After about 3 weeks of being unable to fly P3D because of joystick loss if any menu was activated, Plane swapped, or setting changed. Today I decided to Re-Install P3D. I figured since I first purchased P3D, then the Windows 8.1 update rolled out, which I upgraded to and began to experience the joystick loss every single time. Today I ran the installer again. it asked if I wanted to "Repair" I said yes! it took about an hr to finish, I almost closed it! BUT so glad I didn't. after set up was done and computer restarted, I was able to run it just fine. I opened all the menus, even loaded different controller options I had saved for twin engine planes. I changed planes mid flight, changed time preview mid flight No joystick loss! I made 5 flights, 2 over 30 min, all while switching settings trying to trigger Joystick loss. so far so good! Now I know this might now work for everyone, but if you did upgrade OS after installing P3D. then try a repair if you have an hr to spare. cant hurt! even if your situation is completely different, try the repair! I'm finally back in the air!



-J



EDIT -



Day 2 after "repair" back to all controllers being lost.

Kennair
Posts: 18
Joined: Fri Feb 04, 2011 11:11 pm

Postby Kennair » Sat Feb 08, 2014 5:08 pm

Guys, I had the same problem with my newly purchased gaming laptop and I persevered with fault finding and workarounds for a week before stumbling on the only solution to all my problems..... load windows 7! Don't bother with Windows 8 or 8.1 unless you like to torture yourself unnecessarily. Once I loaded Windows 7 all my controller and graphics issues were solved.



Ken.

CAF440
Posts: 20
Joined: Fri Dec 10, 2010 5:25 am

Postby CAF440 » Sat Feb 08, 2014 6:48 pm

No Issue's FSX W8 and 8.1. Lockheeds P3D V1.4 although has the famous 2.0 drop stick error also.

Celis
Posts: 275
Joined: Tue Apr 17, 2012 3:10 pm

Postby Celis » Thu Feb 13, 2014 11:51 am

Thanks Wes,



Running win8.1

Joystick properly running on any other sim or game.

Saitek X65F





Alex

Potholer
Posts: 14
Joined: Thu Nov 08, 2012 6:50 pm

Postby Potholer » Sat Feb 15, 2014 9:57 am

To add my two penny'th - after installing a clean copy of P3DV2.1 the only problem that I'm consistently getting is a dropout of my Saitek Pro Yoke controller whenever the Settings menu is selected. Only the 'Mouse' options then become available so that changes to my yoke assignments cannot be made.



Win 8.1 64 bit

Intel i7-4770K @ 3.5 GHz

16 GB RAM

NVIDIA Titan



Maybe time for another patch? Thanks for cleaning up all the other problems that I had with V2.



Mike

bill27612
Posts: 4
Joined: Sat Jan 18, 2014 9:25 pm

Postby bill27612 » Sat Feb 15, 2014 11:47 am

Installed update and still loose my AV8R when changing aircraft.

I also loose joystick settings.

I really don't believe this product is ready for release but they have my money.

Definitely not recommended.

jazbas
Posts: 2
Joined: Sat Oct 16, 2010 11:05 pm

Postby jazbas » Sat Feb 15, 2014 4:43 pm

Still the same problem with Saitek X52 Pro here with 2.1 also...

ockwellk
Posts: 29
Joined: Tue Mar 05, 2013 6:50 am

Postby ockwellk » Sun Feb 16, 2014 5:29 am

Can't get the throttle to work on the X52, it calibrates fine in the control menu, but never works in the sim.



Ken

jmejia
Posts: 3
Joined: Thu Nov 28, 2013 1:35 am

Postby jmejia » Mon Feb 17, 2014 2:54 am

I have the same issue Potholer has. the patch (2.1) Did fix my controllers being lost. however although the controls work, (with exception to my trim wheel), they do not display in controller settings. all I see are "mouse" options.

CaBrA
Posts: 16
Joined: Wed Oct 02, 2013 1:38 pm

Postby CaBrA » Tue Feb 18, 2014 5:09 pm



Quote:

Quote from _alioth_ on November 25, 2013, 18:43

Im loosing not the joystick, but force feedback of my MS sidewinder force feedbak 2




Same here but with logitech FF joystick


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 8 guests