Frequently loosing the joystick

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
gpugnet
Posts: 10
Joined: Wed Nov 28, 2012 7:11 pm

Postby gpugnet » Mon Nov 25, 2013 4:54 pm

Hello Prepar3D team,



I am facing an issue : I frequently loose my joystick. The only way for prepar3d v2 to detect it again is to restart prepar3d.



The joystick is a Saitek AV8R-01.



If any other information are needed, please feel free to ask :)




User avatar
ITholic
Posts: 4
Joined: Thu Dec 13, 2012 1:54 pm
Location: Germany
Contact:

Postby ITholic » Mon Nov 25, 2013 6:01 pm

I got the same problem. My stick is a logitech G940. Seems to be a general issue :?
Prepar3D since v2 ... www.simbuilders.eu

_alioth_
Posts: 3
Joined: Mon Nov 25, 2013 8:10 am

Postby _alioth_ » Mon Nov 25, 2013 6:43 pm

Im loosing not the joystick, but force feedback of my MS sidewinder force feedbak 2

David Brice
Posts: 119
Joined: Mon Oct 24, 2011 3:47 am

Postby David Brice » Mon Nov 25, 2013 11:14 pm

I'm also finding on task switch or vehicle select that I lose my USB Thrustmaster Warthog device. It's still showing in the device list in Windows but not in P3D. Sometimes, but rarely, when performing the same task switch or unfocus/focus on P3D, the stick comes back.


Arwen
Posts: 30
Joined: Wed Jul 11, 2012 3:15 pm

Postby Arwen » Tue Nov 26, 2013 12:17 am

My Saitek X52 joystick and throttle worked perfectly until I tried loading the first flight (first takeoff) tutorial. Now it keeps getting turned off (all the LEDs go off, like it was unplugged).

Dalton0190
Posts: 4
Joined: Mon Sep 23, 2013 11:54 am

Postby Dalton0190 » Tue Nov 26, 2013 3:19 pm

Same for me with my Saitek Pro Flight Yoke and Pedals.

Loosing the devices in Prepar3d but they are still visible and working in Windows.

After a restart of Prepar3d everything works for a while again. :-(

gpugnet
Posts: 10
Joined: Wed Nov 28, 2012 7:11 pm

Postby gpugnet » Tue Nov 26, 2013 3:42 pm

I noticed that problem happen when I change the plane in the simulation. Once the new plane is loaded, I lost the joystick.

WBard
Posts: 1034
Joined: Mon Aug 16, 2010 7:23 pm

Postby WBard » Tue Nov 26, 2013 9:22 pm

What operating system are you all under? We'll definitely look into this.

Dalton0190
Posts: 4
Joined: Mon Sep 23, 2013 11:54 am

Postby Dalton0190 » Wed Nov 27, 2013 1:08 am

I am using Windows 8.1 without FSUIPC until Pete gives us an updated Version.

Never had this Problem with FSX and active FSUIPC.

BTW: We are talking about Prepar3d v2, i can not remember that i had this issue in v1.4 but i didnt use it much.

dbrum
Posts: 5
Joined: Thu Oct 06, 2011 1:27 am

Postby dbrum » Wed Nov 27, 2013 1:38 am

I have the same problem - I have 2 sticks and saitek yoke, pedals and CH Throttles - all of them exhibit the exact same behaviour.



One other odd thing I see - anytime I start a flight or change planes or location, the throttle goes to 100% and the rudder seems to be in constant LEFT position, so the plane starts spinning around in circles. I can hit SLEW mode and the plane will spin 360 non-stop. Sometimes it stops, sometimes it doesn't. This only occurs in v2 - i can use all sticks/pedals etc just fine in v1.4 which is still installed.

NLPER
Posts: 65
Joined: Wed Oct 09, 2013 2:37 pm

Postby NLPER » Wed Nov 27, 2013 3:08 am

I have the same problem. The Win 8 system is operational

_alioth_
Posts: 3
Joined: Mon Nov 25, 2013 8:10 am

Postby _alioth_ » Wed Nov 27, 2013 4:38 am

Windows 7 x64 here.


triton
Posts: 8
Joined: Sun Apr 01, 2012 8:11 pm

Postby triton » Wed Nov 27, 2013 4:44 am

I have the same Issue Windows 8.1x64, I'm using a saitek X52 and saw it with windows 8.0, I never saw it with windows7x64 to be fair it's not unique to P3Dv2 but if you can help find an answer you'll be a hero :)

terrapin
Posts: 5
Joined: Mon Nov 25, 2013 8:57 am

Postby terrapin » Wed Nov 27, 2013 5:03 am

IMHO it's a Win 8 / Win 8.1 issue NOT related to p3d - had this with fsx also under Win 8/ 8.1. All net-based "fixes" didn't work reliably. As soon fsx/p3d loses focus, the joystick (..all joysticks I tried) is gone. A workaround could be to map all axes through FSUIPC.



I wasn't able to reproduce the error under win7 with fsx...in other words: I won't use Win 8 for simming until MS fixed the issue.

minime
Posts: 1198
Joined: Mon Jun 10, 2013 4:33 pm

Postby minime » Wed Nov 27, 2013 5:26 am

Yes, same problem, Windows 8.1.



Fastest fix is to unplug the joystick and plug it in again.



I did not have the problem in v1.4 on Windows 8. But maybe thats just me, or its the Windows 8.1 update I installed.


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 4 guests