Software Freeze and Display Goes Black

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
hollywood_0760
Posts: 5
Joined: Tue Aug 21, 2012 4:17 am

Software Freeze and Display Goes Black

Postby hollywood_0760 » Thu Apr 18, 2019 10:00 pm

Software failure is typically a video freeze in flight or infrequently while taxiing, with display next going black, and audio (aircraft engine sound) still continuing. Sometimes it gives a Windows error message that P3D has stopped working, then crashes to desktop, but typically not. Windows does not crash. I do not get black poly rendering or frame stutters ahead of the freeze. I have read elsewhere that the described symptoms typically are a result of exhausting video RAM, but want to know how I can confirm. Any suggestions in config changes, additional advanced settings not included in the config file (noted in SDK), etc is appreciated. If it is a given the issue with these symptoms is always that the system is out of video RAM, that confirmation would also be welcome. I have tried many combinations of reducing video quality settings (though somewhat random), and they did not correct the problem. Think I will try locking FPS to 24 for a while to see if there is any reduction in freezes.

System Info:
Win 7 PC
Core i7 3.6 GHz
8GB shared system RAM
NVIDIA gForce 970 4GB
11.9 GB total avail graphics
DirectX 11
All drivers current
P3D v4.4

My primary computer which was a 2018 with Core i7 system running Win10, 16 GB RAM, NVIDIA gForce 1070 8GB, etc. burned recently in a house fire. P3D ran fine on it with just about everything maxed and 4096 texture resolution. Have had to revert to older desktop system listed above until I can replace the newer computer. Was running FSX on this older system before, not P3D.

I have used system monitor to watch the CPU load, and it never comes close to maxing out processor memory on any core before P3D freezes. I am running P3D at what seems a significantly dialed back config, and am shocked if this still uses all 4 GB of available video RAM. Am hoping it is something else that can be resolved short of changing the graphic card. Typical P3D settings are:

Video mode = 3840x2160x32 (default res for the Samsung 28" monitor)
Frame Rate locked at 35, and am getting 28-35 except at detailed airports such as FSDT/Flightbeam where they may drop to below 20 short term on final.
Traffic set to around 40%, and using only default P3D AI except for MAIW mil traffic.
Autogen is off, and using mostly MegaScenery photoreal with default terrain, although terrain mesh typically set pretty high at 1-2m. But have tried backing off with little noticable effect.
I do generally use complex payware aircraft such as the VRS FA18 Superbug and PMDG 737, which obviously do contribute to the load. I have for many years seen people posting their configurations and related frame rates, and was always curious why my system seemed to always lag much further behind although my graphics card and processor was better. I rarely could get over 35 fps with moderate FSX settings, but did not care because at 30 fps the controls are smooth enough (except for inflight refueling maneuvering... ha!).

From P3d.cfg (obviously there are more settings than listed below, but these are the ones that likely indicate the level of complexity configured):

[GRAPHICS]
TEXTURE_MAX_LOAD=2048
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=1
DYNAMIC_LIGHTING=1
DAWN_DUSK_SMOOTHING=1
LENSFLARE=0
HDR=0
DYNAMIC_REFLECTIONS=2
SHADOW_QUALITY=1
SHADOW_DRAW_DISTANCE=1
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=0
PARTICLES_SHADOWS_CAST=0
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
OPAQUE_SHADOW_TEXTURE_SIZE=2048
TRANSLUCENT_SHADOW_TEXTURE_SIZE=512
OPAQUE_SHADOW_DRAW_DISTANCE=2000
TRANSLUCENT_SHADOW_DRAW_DISTANCE=2000
EFFECTS_QUALITY=1
EFFECTS_DISTANCE=1
TEXTURE_QUALITY=3
IMAGE_QUALITY=0

[DISPLAY]
TEXTURE_FILTERING=4
MSAA=0
SSAA=4
VSYNC=1
FXAA=1
TRIPLE_BUFFER=1
IMAGE_COMPLEXITY=5
SCENERY_DRAW_DISTANCE=32000.000000

Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 17 guests