Forward View Issue

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
Posts: 5
Joined: Wed Jun 28, 2017 6:30 pm

Forward View Issue

Postby rseijo » Wed Apr 10, 2019 2:18 pm

Hello, I just upgraded from v4.2 to v4.4 with no issues during that process. I am however experiencing a view problem when using the Hat Switch on the CH Flight Sim Yoke. When Panning around to any direction (look left, left forward, right, right forward etc.) upon release of the Hat the view goes to a FORWARD DOWN VIEW. Does not return to FORWARD VIEW.

In P3D the Hat Switch 1 is assigned to View (pan). This has always worked regardless of the version... return to Forward View upon release of the Hat Switch.

I renamed the camera.cfg so P3D could rebuild the CFG; problem remains
Confirmed there are no other key or button mappings in FSUIPC.
Confirmed there are no other Controls Key or Axis assignments in P3D.

I have a temporary workaround in-place, using the "F" key on Look (reset to forward view) in P3D Key Assignments. Then mapped it to the Hat Switch / Forward Button in FSUIPC on release of the button. This however has an impact when using outside views, it will snap back to tail view in assigned to the other Hat Switch Buttons.

Just as FYI, using iFly 737NG Pro CBE - Cockpit Builders Edition. The upgrade process to the latest iFly SP version was problem free.

Any suggestions?

Thanks Ralph!

User avatar
Rob McCarthy
Lockheed Martin
Posts: 2758
Joined: Wed Aug 24, 2011 1:37 pm

Re: Forward View Issue

Postby Rob McCarthy » Wed Apr 10, 2019 2:59 pm

Hi Ralph,

Do you still see this issue with FSUIPC disabled? Have you tried renaming the Prepar3D.cfg so that will rebuild as well? Also going through our general debugging steps may help isolate what's causing the problem: ... 2&t=123246

Rob McCarthy
Rob McCarthy
Prepar3D® Core Lead

Posts: 5
Joined: Wed Jun 28, 2017 6:30 pm

Re: Forward View Issue

Postby rseijo » Wed Apr 10, 2019 7:45 pm

Thanks for the quick reply!

I performed the less intrusive troubleshooting checks; disabling FSUIPC, unplugging the USB device and rebuilding Prepar3D.cfg. Problem continues...

Then decided to check the stock P3D Aircraft and the trouble is NOT occurring. I think my problem is with the iFly add on aircraft. I'll post something on the iFly Forum to see if the have any suggestions.

I'll update this post on the outcome of my contacting the iFly Team.

Thanks again and I appreciate the support!

Best regards

Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 25 guests