Page 1 of 1

Conflict between sound (Q) and frame rate

Posted: Sat Mar 30, 2019 7:14 am
by tacito
I installaed Prepar3D_v4_Academic_4.4.16.27077 (two days ago)
for me it's the first installation of P3D
installation successful, but when start P3D4 it start with audio turned off.
I press the Q key and the frame rate collapses, unusable!!

I did various tests, disconnected all USB devices, updated idrivers
please, some help. thank you so much

my PC:
GTX1070 8GB x2 SLI
Windows10 Home 64bit
HOTAS Warthdog Joy Throttle and pedal

p.s. with another simulator DCS (A-10C etc..) No problem with audio/frame rate

Re: Conflict between sound (Q) and frame rate

Posted: Sat Mar 30, 2019 3:51 pm
by downscc
I've never seen this reported here or in the AVSIM forum for P3D. You should assume that this interaction between sound and performance is strictly based on something in your system.

Here's a few ideas: Make sure that the sound setting in P3D is set to your default Windows sound device and double check the Windows sound configuration. Make sure you do not have a HD Audio device selected unless you are actually using this driver, which is normally installed by NVidia installers. In other words, only have one audio device selected.

Please report back when you find the solution, this is an interesting one.

Re: Conflict between sound (Q) and frame rate

Posted: Sun Mar 31, 2019 11:10 am
by tacito
Hi, Thanks for the reply!

in device management:
I had 2 NVIDIA Hight Definition Audio
1 NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
and Realtek(R) Audio

in input/output audio
Speaker (Realtek(R) Audio)

Now I have disabled all NVIDIA
in P3D Options-Sound, I have selected Default device audio

But it does not work!
when start P3D4, it start with audio turned off, the FPS high,
but as soon as I press Q to activate the sound, everything stops.

maybe there is something wrong with the P3D configuration files.

Re: Conflict between sound (Q) and frame rate

Posted: Tue Apr 02, 2019 2:52 pm
by tacito
ok just to report
I found the winning combination...maybe:
I reactivated all device in windows10 device management.
then, in P3D Options-Sound, I have selected Speaker (Realtek(R) Audio) and
in windows10 audio playback device (in the bottom bar) I have selected MSI MAG271C (Hight Definition Audio)
now the audio of P3Dv4 works and FPS are ok!

....but I don't have audio in windows10 and other applications (DCS A10C)
but I just need to change the playback device in the bottom bar, and audio windows10 is ok

Re: Conflict between sound (Q) and frame rate

Posted: Sat May 04, 2019 9:52 pm
by AA752
Has anybody else found a more permanent solution to this? I am having a similar issue. I just installed a new NVIDIA GPU and am suffering massive frame loss (100 fps to 5 fps) when I unmute the sound with my headphones chosen as my playback device in P3D. I know it is a GPU issue, because if I choose to play audio through my monitor, the frame rate is steady whether muted or not.

I have not had this issue with any other games, and I have tried every combination of disabling devices, drivers, uninstalling drivers, disabling NVIDIA audio, nothing works.

Re: Conflict between sound (Q) and frame rate

Posted: Sun May 05, 2019 6:39 pm
by AA752
Update in case any other unfortunate soul is suffering from this. I was on the verge of wiping everything and starting over with a fresh install of windows, but before I did that unfortunately deleted every single driver related to audio or displays and made sure to install only the drivers from my motherboard and monitor manufacturer’s website. It works now!