dxgi error device removed...

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
Alexis_67
Posts: 15
Joined: Tue Dec 27, 2016 2:20 pm

dxgi error device removed...

Postby Alexis_67 » Fri Jun 29, 2018 6:26 pm

Hello,

I receive this error since the Nvidia driver update. On P3DV3 and V4. A solution for this problem?

Image

Image
CPU: Intel i7-4790k @4.6Ghz | GPU: MSI GTX1070Ti | MoBo: MSI Z97 Gaming 5 | OS: Win10 64bit 1809 | RAM: Corsair 2X8GB DDR3 1886Mhz | HD: 2.3TB | SSD: Samsung 850Pro 256Go ( Système + P3D ) | Sims: P3D V4.4 |

User avatar
downscc
Posts: 1116
Joined: Mon Dec 01, 2014 5:46 pm
Location: KCRP

Re: dxgi error device removed...

Postby downscc » Sat Jun 30, 2018 5:11 pm

Think about your question for a moment. Things worked, you changed something, things don't work. Any clues? Try using the DDU to clean out all vestiges of a display driver and install a new one.
Dan Downs
KCRP

pracines
Posts: 119
Joined: Mon Nov 25, 2013 4:01 am

Re: dxgi error device removed...

Postby pracines » Sat Jun 30, 2018 5:56 pm

Some detailed troubleshooting steps to try:

https://answers.ea.com/t5/Crysis-Games/ ... -p/1118490
Win 10 64bit | Z97 Pro | i7 4790 4.6GHz | Corsair Hydro Series H80i GT Liquid Cooling |
16GB RAM | GTX 980 | Oculus Rift | 1TB Samsung EVO 850 SSD | 2TB WD Black 7200 RPM SATA 6.0Gb/s

georgio52
Posts: 35
Joined: Fri Jan 04, 2013 5:13 am
Location: Illinois USA

Re: dxgi error device removed...

Postby georgio52 » Mon Jul 02, 2018 2:58 am

the problem is between NVidia and NVidia Inspector Limiter setting.. I tried all the last NVidia drives " 397.93 , 398.11 , 398.36 , with NI BUT no positive result . I tried also NVidia 397.64 drive with NI ,and I did not have error .. I also tried the NVidia forum but no one gives a positive solution . I did install again NV 398.36 without NI flew for 6 hrs and I had no problem.. Something is happening with the latest NVidia drives...


George

User avatar
Beau Hollis
Lockheed Martin
Posts: 1876
Joined: Wed Oct 06, 2010 3:25 pm

Re: dxgi error device removed...

Postby Beau Hollis » Mon Jul 02, 2018 12:07 pm

Can you provide some more details? Do you ever see this issue without tweaking via NI? Modifications to the graphics profile outside of Nvidia control panel are likely not supported officially by Nvidia. Does it crash using default settings? Does it crash on startup or after performing a specific action such as opening a new window, or moving a window to new display?
Beau Hollis
Prepar3D Software Architect

georgio52
Posts: 35
Joined: Fri Jan 04, 2013 5:13 am
Location: Illinois USA

Re: dxgi error device removed...

Postby georgio52 » Mon Jul 02, 2018 3:08 pm

I did not have a problem until 397.64 driver I used NVidia and NI together.. the problem started from 397.93 driver .I did not use default settings in Prepar3D ,the problem starts with error DXGI after 5 - 20 min in flight. I don't open a new window ,and I did not open window to new display.. Now I use the 398.36 NVidia driver,without the NI and I don't have a DXGI error.... my Rig GPU AND CPU spesifications are Graphics: EVGA GeForce GTX 1060 Superclocked 6GB GDDR5 | Processor: I7-6700K CPU 4.00GHz ..and my addons : ASP4 BETA, FS Real Time , SimElite, Navigraph, PMDG 777x , EditVoicepackXL , Traffic Global , all these addons are compatible with P3D v4.3...


George

User avatar
downscc
Posts: 1116
Joined: Mon Dec 01, 2014 5:46 pm
Location: KCRP

Re: dxgi error device removed...

Postby downscc » Mon Jul 02, 2018 4:17 pm

I have not found a reason to use the NI since P3D when from v2 to v3. And now with v4, the tweaks necessary are down to a few items in the prepar3d.cfg.
Dan Downs
KCRP

User avatar
Beau Hollis
Lockheed Martin
Posts: 1876
Joined: Wed Oct 06, 2010 3:25 pm

Re: dxgi error device removed...

Postby Beau Hollis » Tue Jul 03, 2018 2:00 pm

That's for the additional information. It doesn't sound like there is anything we can do from within the app to detect/correct the issue. We recommend you continue using Prepar3D without the NI tweaks for now. Hopefully the issue will be resolved in a future driver update.

Thanks
Beau Hollis
Prepar3D Software Architect

georgio52
Posts: 35
Joined: Fri Jan 04, 2013 5:13 am
Location: Illinois USA

Re: dxgi error device removed...

Postby georgio52 » Tue Jul 03, 2018 4:38 pm

I hope NVidia makes driver to work with P3D without being dependent on NI settings..These settings may become available in NVidia Control Panel in future , but now without the use of NI have a lot stutters in P3D..Any way I downloaded back the 397.64 driver again by using NI and P3D v4.3 works smooth..

George

pracines
Posts: 119
Joined: Mon Nov 25, 2013 4:01 am

Re: dxgi error device removed...

Postby pracines » Fri Jul 06, 2018 5:39 am

Win 10 64bit | Z97 Pro | i7 4790 4.6GHz | Corsair Hydro Series H80i GT Liquid Cooling |
16GB RAM | GTX 980 | Oculus Rift | 1TB Samsung EVO 850 SSD | 2TB WD Black 7200 RPM SATA 6.0Gb/s

georgio52
Posts: 35
Joined: Fri Jan 04, 2013 5:13 am
Location: Illinois USA

Re: dxgi error device removed...

Postby georgio52 » Sat Jul 07, 2018 1:44 am

I tried this method before with Registry Editor,but the problem with error remains the same for me.. As mentioned above , the latest drivers create this error. At the moment i'm with the old driver NV 397.64 and i'm fine..

AnkH
Posts: 194
Joined: Tue Sep 23, 2014 1:20 pm

Re: dxgi error device removed...

Postby AnkH » Tue Jul 10, 2018 7:43 am

I also suffered the first time ever from this very error message yesterday after 2h into flight. Very annoying. I already read elsewhere that it might be related with Nvidia Inspector so for my next flights I wont use NI anymore. Could it really be that simple? We will see...
------------------
Chris

Hardware: i7 8700K@5.0GHz, 2x16GB DDR4 3200MHz CL14 RAM, Gigabyte Aorus GTX-1080Ti OC, Samsung SSDs (250GB for OS, 1TB for P3D), Windows 10 Home

JPS2K5
Posts: 15
Joined: Fri Jul 07, 2017 8:07 am

Re: dxgi error device removed...

Postby JPS2K5 » Wed Jul 11, 2018 9:03 pm

I'm getting this error too. I have never ever used NI. I did do some tweaks in Nvidia Control panel though, will try to see what happens when I revert them.

georgio52
Posts: 35
Joined: Fri Jan 04, 2013 5:13 am
Location: Illinois USA

Re: dxgi error device removed...

Postby georgio52 » Thu Jul 12, 2018 12:15 am

stick to 397.64

JPS2K5
Posts: 15
Joined: Fri Jul 07, 2017 8:07 am

Re: dxgi error device removed...

Postby JPS2K5 » Fri Jul 13, 2018 8:49 am

I reverted my Nvidia control panel settings, no joy. The only thing that seems to work is indeed go back to an older driver.

However, saying that it's a driver problem and not a P3D problem seems a bit odd to me. After all, none of my other programs/games have any problem at all.


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: Google [Bot] and 2 guests