[RESOLVED] P3D v4.2 G-Sync not working...

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
chris512
Posts: 14
Joined: Thu Sep 22, 2011 8:42 pm

[RESOLVED] P3D v4.2 G-Sync not working...

Postby chris512 » Sat May 12, 2018 6:14 pm

Hi,

Has anyone got G-Sync working with P3D v4.2? I saw it work once, then it stopped and hasn't worked since.

I've tried reinstalling my nVidia Driver. (397.64) I've also tried setting it to "Enable G-Sync for Full Screen mode" and also "Windowed Mode" neither seem to work. I'm watching the built in frame counter on my Asus Screen, it does show G-Sync working with X-Plane, so I know the Screen Counter is working.

I'm running the latest Windows 10 Spring Creators Update. (Version 1803) OS Build 17134.48.

Can someone help me please?

chris512
Posts: 14
Joined: Thu Sep 22, 2011 8:42 pm

Re: P3D v4.2 G-Sync not working...

Postby chris512 » Sat May 12, 2018 7:23 pm

A bit of progress... I did a clean install of the nVidia Drivers by using the tool available on this thread.

G-Sync works for the first run. Then after restarting WIndows 10, it stops working...

Chok
Posts: 17
Joined: Thu Aug 25, 2016 8:15 pm

Re: P3D v4.2 G-Sync not working...

Postby Chok » Sat May 12, 2018 7:57 pm

A bit of progress... I did a clean install of the nVidia Drivers by using the tool available on this thread.

G-Sync works for the first run. Then after restarting WIndows 10, it stops working...
I had a similar issue once, try and disable windows fast boot and see if that helps.

chris512
Posts: 14
Joined: Thu Sep 22, 2011 8:42 pm

Re: P3D v4.2 G-Sync not working...

Postby chris512 » Sat May 12, 2018 9:02 pm

OK thanks, I'll give that a go...

After an evening spent trying to get this to work I've discovered the following:

If I do a clean install of the nVidia Driver (397.64), restart and run P3D, it works. Smooth as butter, even with the FS Labs and Dynamic Lighitng. Glorious! If I then close and restart P3D, it still works... If I restart Windows 10 and then run P3D it won't work. I have to do a clean install of the nVidia Driver again. I'd tried this cycle 3 times now and it happens every time. If I run X-Plane, the G-Sync works whatever I do. So this is just a P3D issue so far. I really don't want to have to do this every time I want to use P3D! It's unusable without G-Sync for me.

chris512
Posts: 14
Joined: Thu Sep 22, 2011 8:42 pm

Re: P3D v4.2 G-Sync not working...

Postby chris512 » Sat May 12, 2018 9:08 pm

Changing Fast Boot to Off didn't work... Thanks anyway. I hope someone at Lockheed Martin will be able to help. My G-Sync is stuck at the full refresh again now, until I go through the process outlined above again...

AnkH
Posts: 121
Joined: Tue Sep 23, 2014 1:20 pm

Re: P3D v4.2 G-Sync not working...

Postby AnkH » Mon May 14, 2018 8:52 am

I wonder how you manage to have your settings as such as G-Sync makes any difference... I know I tend to rather high settings, but as G-Sync only works from 30FPS upwards, I turned it off for P3D anyway. I don't want to lower my settings that much that my FPS are constantly above 30FPS... And if the FPS are fluctuating between FPS above and below 30, my G-Sync monitor flickers visibly. Not nice to see...
------------------
Chris

Hardware: i7 8700K@5.0GHz, 2x16GB DDR4 3200MHz RAM, Gigabyte Aorus GTX-1080Ti OC, Samsung SSDs (256GB for OS, 1TB for P3D), Windows 10 Home

chris512
Posts: 14
Joined: Thu Sep 22, 2011 8:42 pm

Re: P3D v4.2 G-Sync not working...

Postby chris512 » Tue May 15, 2018 7:27 pm

Is there someone from Lockheed Martin that could help me with this please? I've reached the end of my knowledge now...

planoris28b2
Posts: 5
Joined: Sat Jan 20, 2018 12:12 am

Re: P3D v4.2 G-Sync not working...

Postby planoris28b2 » Mon May 21, 2018 6:19 pm

I did this and it works without G-SYNC without any problems at 50 fps

=> http://www.prepar3d.com/forum/viewtopic.php?t=128802

planoris28b2
Posts: 5
Joined: Sat Jan 20, 2018 12:12 am

Re: P3D v4.2 G-Sync not working...

Postby planoris28b2 » Mon May 21, 2018 7:09 pm

The ideea, i belive is that you should not give much work to the processor and graphic card that is why i say that you sould block the framerate to 100 from P3D if you are running a 100 Hz monitor then block it to 50 from Riva tuner (it's half refresh rate), or if your running a 60 Hz monitor block to 60 in P3d and at 30 in riva tuner. I don't know exactly what is the catch but it works (if u set half refresh rate in Nvidia inspector). Maybe is Bullsh.t what i'm saying but it worked on 2 computers.

planoris28b2
Posts: 5
Joined: Sat Jan 20, 2018 12:12 am

Re: P3D v4.2 G-Sync not working...

Postby planoris28b2 » Mon May 21, 2018 7:11 pm

... and definitely you should use "SIMstarter NG" from aerosoft, the app is doung magic in stopping programs what you don't need when you fly. Try it.

chris512
Posts: 14
Joined: Thu Sep 22, 2011 8:42 pm

Re: P3D v4.2 G-Sync not working...

Postby chris512 » Mon May 28, 2018 6:10 pm

Thanks for the suggestions guys. I'll give them a shot. I would like to get this G-Sync issue solved though. It's really great when it works, and I paid a fortune for my G-Sync screen!

vmounier
Posts: 21
Joined: Sun Apr 12, 2015 4:47 pm

Re: P3D v4.2 G-Sync not working...

Postby vmounier » Wed Jun 06, 2018 11:54 am

Coming at this from a different angle (I was researching the G-Sync issue elsewhere as it might not be P3D-related), someone mentioned terminating the dwm.exe process (desktop). It restarts immediately and this might help your G-Sync issue even after you have rebooted Win 10. I would close any display-sensitive apps before doing so.
Vincent Mounier

chris512
Posts: 14
Joined: Thu Sep 22, 2011 8:42 pm

Re: P3D v4.2 G-Sync not working...

Postby chris512 » Sat Jun 16, 2018 7:01 pm

I solved this problem in the short term by downgrading to Windows 8.1...

How's that for progress...


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 4 guests