Out of memory error on start up?

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
Posts: 12
Joined: Sun Dec 20, 2015 7:36 pm

Out of memory error on start up?

Postby poosd » Wed May 24, 2017 8:31 pm


I have been using P3dv3.4 now for some time with minimal problems. Now suddenly I can't load the program at all. When attempting to load P3d I get the error "Your computer has run out of available memory. Please restart Prepar3D and select different graphics, scenery, or traffic settings." I would gladly do as told, but....I can't get the program to load to make these changes? I have been on line and looking for Windows 10 solutions, but don't really understand what they are saying or how it relates to P3dv3.4.

1. Where are the appropriate config files needed to change these now too high settings, and once I find this file, what and where are the changes that need to be made in order to get P3d to load.

2. How can I prevent this issue in the future?

Currently running Windows 10 and P3Dv3.4 plus Orbx Global Base, Vector, OpLC Europe and North America, several Regions, plus numerous other add-ons.

Machine stats: Windows 10
Intel Core i7-4790K CPU @ 4.00GHz, 4.00GHz
RAM = 32.0 GB of installed memory
64-bit Operating System, x64 based processor
NVIDIA GeForce GTX 780Ti

I have two hard drives. One has 206GB free out of 983GB available. The other (where P3d lives) has 3.28 TB used out of 3.63 available.

Thank you in advance for your knowledge and help.

Posts: 61
Joined: Sun Jun 10, 2012 6:27 pm

Re: Out of memory error on start up?

Postby farman » Wed May 24, 2017 9:10 pm

Hi Poosd, I had the very same error as yours; I posted a request for help weeks ago; unfortunately to no avail so far. Very disappointing, actually. In my case this occurred after flying both the CaptainSim B-52 and the B-707, even after deleting a line in the VC panel, as suggested by some user.
Anyway, no answers at all is a very bad customer satisfaction service.

Posts: 12
Joined: Sun Dec 20, 2015 7:36 pm

Re: Out of memory error on start up?

Postby poosd » Thu May 25, 2017 12:02 am

Just came up with a temporary fix. On your computer go to

C:\Users\YourUserName\AppData\Roaming\Lockheed Martin\Prepar3D v3. Find the file named Prepar3D.cfg. In this directory, In the same directory I had a file also named Prepard3D-Copy.cfg. I believe that this copy was created the last time P3Dv3 actually loaded correctly. I took a shot and renamed the Prepar3D.cfg to Prepar3D.org.cfg (i.e made a back up in case I screwed something up) and renamed the copy, Prepard3D-Copy.cfg to just plain Prepard3D.cfg. I then tried to start P3d and guess what? It loaded properly.

When I compared the two cfg files I noticed that the one that worked had two entries removed. It did not have an entry for the Estonia Migration Tool in it, and a Captain Sims C130 that I had loaded using the EMT was also gone. I have had both the CS C130 and the EMT loaded on my P3d for quite some time without any problems.

I'm still very interested in hearing from any P3dv3.4 guru's out there about this problem, as I realize that what I've done here may be nothing more than dumb luck, but since at least two P3d customers had this same issue and got no response from anyone on the forums, it's possible that others have had the same problem and just given up.

Fulvio...I make no promises about any of this. My actions were simply a wild guess gone right. Maybe someone with REAL P3d knowledge will now jump in and educate us both a bit.

Good luck,

Posts: 12
Joined: Sun Dec 20, 2015 7:36 pm

Re: Out of memory error on start up?

Postby poosd » Thu May 25, 2017 12:37 am

God I hate mistakes!

In my previous post, everywhere where I state "Prepar3D.cfg", it should read "dll.xml" (opened with Notepad). Still looking for help with this. Should have tested more. Went and tried loading again and my original error came up again.


User avatar
Posts: 66
Joined: Mon Apr 09, 2012 12:15 pm

Re: Out of memory error on start up?

Postby DaveWG » Thu May 25, 2017 7:30 am

I've had this type of OOM in the past. It can happen if your default saved flight gets corrupted for some reason.
In my case I had saved a default flight with an aircraft I was beta testing for a friend. He sent me an updated version, so I deleted the old aircraft and replaced it with the new one. Unfortunatly, he'd changed the "title=" section, so as far as P3d was concerened the aircraft in my saved flight it was trying to load didn't exist and threw up this OOM error. A bit of manual editing of the saved flight file and all was OK.
Some Captain Sim aircraft add some extra info to the saved flight file as well, so next time P3d will crash trying to load.
You have to remove this extra data.

Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 53 guests