P3d 4.3 Control settings not saved

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
RMM Guam
Posts: 16
Joined: Mon Sep 26, 2016 11:54 pm

P3d 4.3 Control settings not saved

Postby RMM Guam » Sun May 12, 2019 10:06 am

I am almost embarrassed to raise this issue. Searching on Google shows this problem has been around for years and years. When presented for the umpteenth time, LM greets this as something new. Not right. Please don't ask me all kinds of questions about my sim gear, or how to duplicate, or unplug this and go mouse only etc etc.

Here I am with ver 4.3 and the same old thing occurs.

I go through the exhaustive process of cleaning up all my devices for unnecessary button settings, putting in the essential buttons, deleting all the unnecessary axis settings, and putting in the essential axis settings.
I have Yoko Yoke, MFG Rudders, Saitek throttle quadrant, Saitek trim wheel.

I save the A2A C172 as a scenario after proving out all the settings are correct.

THEN... do something like
-1- Navigate back to the active airport and runway for a fresh takeoff.
or
-2- Reload the saved scenario
or
-3- Shut down P3d and restart the application.

AND -- all the control settings are frogged up again.

This makes me spend huge amounts of lost time to get the settings fixed. Then they go right back out of whack.

What is the solution? This has been put to LM for years and years. Very frustrating. Please help!

JorgenSA
Posts: 248
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: P3d 4.3 Control settings not saved

Postby JorgenSA » Sun May 12, 2019 12:10 pm

In your post, this sentence looms large:

"Please don't ask me all kinds of questions about my sim gear, or how to duplicate, or unplug this and go mouse only etc etc."

How in the world then are we supposed to be able to help?

Here are some of the things that you should have done already, but that you do not mention that you have done:

1. Update your OS to the latest.

2. Install the latest device drivers for your add-on hardware.

3. Try with one or more of the default aircraft in 4.3.

4. Get FSUIPC v. 5.

Jorgen

RMM Guam
Posts: 16
Joined: Mon Sep 26, 2016 11:54 pm

Re: P3d 4.3 Control settings not saved

Postby RMM Guam » Sun May 12, 2019 8:51 pm

Hi Jorgen..
My reason for saying that is ..
-1- This issue has been raised by numerous users over several P3d versions. All those questions and suggestions like you pose were already answered as not effective. This is a bug and has been recognized by LM as such.
-2- I don't use FSUIPC and should not be required to do so.
-3- Already have a current installation and OS in all respects. This is not a problem with my machine.

All this was addressed in my OP. I explained how to recreated the problem by doing the most ordinary things in the sim.
There are some work around suggestions but LM has yet to provide a clear fix.

But thanks for the willingness to help. This is for LM to advise. I sent a PM to Rob McCarthy requesting his attention.


RMM

JorgenSA
Posts: 248
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: P3d 4.3 Control settings not saved

Postby JorgenSA » Mon May 13, 2019 8:40 am

Begin quote:

"All those questions and suggestions like you pose were already answered as not effective. This is a bug and has been recognized by LM as such."

End quote.

The alleged bug is not in P3D itself, as proven by the fact that only some users experience the drop in FPS. The problem is reportedly in P3D's interactions with some 3rd party add-ons.

Jorgen

JorgenSA
Posts: 248
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: P3d 4.3 Control settings not saved

Postby JorgenSA » Mon May 13, 2019 9:14 am

Another quote:

"Here are some of the things that you should have done already, but that you do not mention that you have done"

End another quote.

Did you, at one time or another, do any of the things I suggested?

Jorgen

RMM Guam
Posts: 16
Joined: Mon Sep 26, 2016 11:54 pm

Re: P3d 4.3 Control settings not saved

Postby RMM Guam » Mon May 13, 2019 11:17 am

Hi Jorgen...

Yes and thanks for your interest and concern. I already indicated that I had taken due steps but your reading of my reply was it seems based on a pre-conceived perspective otherwise. I am not an uninformed or novice user. I have been in flight sim for a long time. Not an IT expert but I know my way around computer systems and software from a user perspective.

Please allow LM to respond here for reasons already explained.

I do not post questions here without first doing a deep search for past responses to the same issues. I read several long threads posted on various forum sites over several years. All that has been explained. This is a long standing bug over several versions.

Please...let LM respond here. Your efforts are appreciated but won't serve for reasons already explained.

thanks
RMM

Senchay
Posts: 98
Joined: Wed Jun 07, 2017 4:47 pm

Re: P3d 4.3 Control settings not saved

Postby Senchay » Mon May 13, 2019 1:17 pm

The alleged bug is not in P3D itself, as proven by the fact that only some users experience the drop in FPS. The problem is reportedly in P3D's interactions with some 3rd party add-ons.

Jorgen
I think you mixed some topics up ^^ I think this isnt about performance but about joystick configurations.
P3D 4.4, I7700K, 2080 RTX, 16GB Ram, Asus Prime Z270K, Win 10

RMM Guam
Posts: 16
Joined: Mon Sep 26, 2016 11:54 pm

Re: P3d 4.3 Control settings not saved

Postby RMM Guam » Mon May 13, 2019 9:09 pm

Hello Senchay...

The topic is as intended. I explained three different ways to cause the ver 4.3 control settings to lose my personalized settings. I never mentioned anything about FPS. I actually don't even monitor FPS.

I use P3d in support of my real world PPL training and find the performance just fine without third party addons for scenery etc. This is why I fly exclusively with the A2A C172 trainer. My hardware is essential for a high level of realism. 60" LED TV / Yoko Yoke / MFG Rudder Pedals / Saitek Throttle Quadrant / Saitek Trim Wheel / Track IR5.

I understand that this is not something that everyone is experiencing. But the issue has nothing to do with performance or FPS or configuration. One of those old threads suggested unplugging all USB devices to find the "offending" device. Did not work then and also not for me.

One other way for settings to be lost was reported as having the computer open up after going into sleep setting. I changed that and the issue still occurred as before. That is... my control settings are lost.

LM has seen this exact same issue over many years. Even happened for one user with graphic settings - which LM directly acknowledged as a code problem...aka bug.

Just thinking that with this same issue arising multiple times over many years, that LM would have it sorted out. Hence my appeal to LM for clarification.

Thanks for the response.

RMM Guam
Posts: 16
Joined: Mon Sep 26, 2016 11:54 pm

Re: P3d 4.3 Control settings not saved

Postby RMM Guam » Sat Jun 01, 2019 9:04 am

In case others come to this thread, there is a workaround.
For those affected, this is a way to save and then recover your control settings and work around the reset to default settings.

Start P3d.
Load a Saved Scenario
Go to Control Settings and establish all key and axis assignments as desired.
Export those control settings and save.
Close P3d

Now each time you start P3d...
Start P3d
Load a Saved Scenario.
Go to Control Settings and IMPORT the saved control settings.

A bit of a hassle each time, but solves the problem. If and when I update to P3D 4.5 version I will come back and post an update regarding this problem as to whether it continues.

Happy Flying.
RMM


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: No registered users and 14 guests