Page 1 of 1

SDK P3Dv4.4 Modeling Tools for Max 2012_x64

Posted: Sun Dec 02, 2018 2:27 pm
by lagaffe
Hi,

After 6 month working on my least scenery about Mirabel with the SDK 4.3.29.25520 I have decided to upgrade to P3Dv4.4 (Prepar3D_v4_SDK_Setup_4.4.16.27106).
The SDK installation was fine and ConfigSDK.Exe was run as Administrator to finish these install.

So I will to create a PBRTexture from the Material Editor and at each try I obtain a plugin handler exception "-- Unknown property:"g_BrdfLutTexture" in (null):DirectX_Shader". In background, Maxscript open the file: SDK_P3Dv4\Modeling\3ds Max\Common\Scripts\Startup\PBRMaterial.ms at line 460.

Is Max 2012 x64 still really supported? Do you have some solution?

Re: SDK P3Dv4.4 Modeling Tools for Max 2012_x64

Posted: Mon Dec 03, 2018 3:56 am
by Beau Hollis
Did you also update the Prepar3D client and content to v4.4? There are new PBR textures included in the content installer.

Thanks

Re: SDK P3Dv4.4 Modeling Tools for Max 2012_x64

Posted: Mon Dec 03, 2018 7:58 am
by lagaffe
Hi,
I proceed with a full uninstall of v4.3, and after that client, content and scenery of the v4.4 were installed on a empty directory: S:\P3D
The version of the SDK has also changed since the 28 Nov: first I find the ***077 and Saturday I can download the **106 revision ... very strange, doesn't it ? No information find about this modification on this forum, or I cann't find it.

In each case, I uninstalled the last SDK, install the new one and apply ConfigSDK.exe with Administrator rights and success.

I can create a Prepar3D texture but when I try PBRTexture ... I have this execption.

Best regards.

Re: SDK P3Dv4.4 Modeling Tools for Max 2012_x64

Posted: Fri Dec 14, 2018 10:57 am
by lagaffe
Nobody use Max2012 - x64 and has intented to install this SDK ?

Re: SDK P3Dv4.4 Modeling Tools for Max 2012_x64

Posted: Fri Dec 14, 2018 1:09 pm
by WarpD
I believe the issue is with Max 2012. It's so old it probably doesn't know anything about PBR. I believe the current minimum supported version of Max is 2014.

Re: SDK P3Dv4.4 Modeling Tools for Max 2012_x64

Posted: Fri Dec 14, 2018 5:10 pm
by lagaffe
Thanks for your answer WarpD,

But this SDK provided 3DSM2012 (32 bits) 3DSM2012 (54 bits) 3DSM2014 (64 bits) 3DSM2015 (64 bits) 3DSM2017 (64 bits) and 3DSM2018 (64 bits) so the 3DSM2012 (64 bits) should be working ...

Re: SDK P3Dv4.4 Modeling Tools for Max 2012_x64

Posted: Sat Dec 15, 2018 12:10 am
by Beau Hollis
It is a limitation of 3DS Max. Directx shaders were limited to DirectX9 in older version of max. Our PBR shader requires DirectX11. We still ship the legacy plugins to support legacy content, but we can't guarantee every new feature works on all versions. Also, for software no longer provided or support by its author, we may not be able to obtain new licenses to test with. We understand there is a substantial financial impact to updating, and we do our best to support legacy versions to the extent that we can.

Thanks