SimConnect Confirmation Required

Pearskin
Posts: 32
Joined: Sun Dec 13, 2015 12:57 am

SimConnect Confirmation Required

Postby Pearskin » Tue Dec 25, 2018 9:20 pm

Please can anyone at P3D (Lockheed Martin) confirm that Simconnect will DEFINITELY work with Windows 10 ver 10.0.17763
and P3Dv4.4. I have two applications that I would like to run using my Local area network; Plan-G and Active Sky for P3Dv4. Neither of these apps will communicate with Simconnect. These apps would definitely work with a previous windows OS but that is no longer the case. I have tried everything I know of to trouble shoot the simconnect system over the last 6 months to no avail. All I am asking at this time is ANYONE able to get simconnect working over a LAN with the current Windows 10 OS and if so which apps you are using. I am almost ready to give up on networking my sim as the frustration is driving me to desperation. I would be glad to hear from ANYONE who can hear my cry for help.

User avatar
Blaunarwal
Posts: 217
Joined: Tue Jun 12, 2012 1:37 pm
Location: LSZH

Re: SimConnect Confirmation Required

Postby Blaunarwal » Wed Dec 26, 2018 9:39 am

Hi

I have it working with Windows 10 Home Build 1809. I use Plan-G one the client and Prepar3d on the server. Plan-G has a pretty good tutorial to configure simconnect but it does not mention you need a simconnect.cfg file in the directory of Plan-G. After adding this, it works perfectly.

Important also is, that your network is working with regards to file access on both sides to the other. I can add my simconnect.xml and simconnect.cfg to this thread tonight when I'm home, after 5 pm GMT. It's aslo written in the Plan-G tutorial very well and the simconnect.cfg you will find with google. Just make sure to find your proper local I.P. adress of the Prepar3D computer and write the same I.P. into both simconnect files and into Plan-G. To get the I.P. adress of your Prepar3d computer open CMD via Windows button, then run ipconfig. The I.P. adress is under IPv4-Adress.

Dan
Image

User avatar
Blaunarwal
Posts: 217
Joined: Tue Jun 12, 2012 1:37 pm
Location: LSZH

Re: SimConnect Confirmation Required

Postby Blaunarwal » Wed Dec 26, 2018 6:27 pm

Here are the simconnect files

On the Prepar3d computer (server) in Users\your name\Roaming\Lockheed Martin\Prepar3D v4 you have this simconnect.xml
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
<Descr>SimConnect</Descr>
<Filename>SimConnect.xml</Filename>
<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>IPv4</Protocol>
<Scope>global</Scope>
<Address>192.168.1.128</Address>
<MaxClients>64</MaxClients>
<Port>4506</Port>
<MaxRecvSize>4096</MaxRecvSize>
<DisableNagle>False</DisableNagle>
</SimConnect.Comm>
</SimBase.Document>

Make sure to use your IP Adress and the filetype is xml.

On the client, where you have Plan-G you need a simconnect.cfg

[SimConnect]
Protocol=IPv4
Address=192.168.1.128
Port=4506
MaxReceiveSize=4096
DisableNagle=0

This is a normal text file.

Make sure both files an Plan-G have the same IP and Port.

My Windows Build is exactly 17763.195.
Image

Pearskin
Posts: 32
Joined: Sun Dec 13, 2015 12:57 am

Re: SimConnect Confirmation Required

Postby Pearskin » Fri Dec 28, 2018 4:33 pm

Ty Dan for you feedback … I am not sure exactly where to place the SimConnect.cfg file. Can you tell me explicitly where to place this file on the client computer. I have been placing in: This PC>Documents. Is that the correct location?

Terry

User avatar
Blaunarwal
Posts: 217
Joined: Tue Jun 12, 2012 1:37 pm
Location: LSZH

Re: SimConnect Confirmation Required

Postby Blaunarwal » Sun Dec 30, 2018 6:50 am

Simconnect.cfg goes into the directory of Plan-G or whatever program you link to Prepar3d.
Image

User avatar
janvaane
Posts: 909
Joined: Mon Apr 23, 2012 11:17 am
Contact:

Re: SimConnect Confirmation Required

Postby janvaane » Sun Dec 30, 2018 10:55 am

|KLM149 | i7-8700k-16GB | Radeon RX580 8GB| flightsimeindhoven.com |


Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 1 guest