WeatherSetModeTheme

User avatar
Opus Software
Posts: 23
Joined: Tue Apr 17, 2012 1:08 pm
Contact:

WeatherSetModeTheme

Postby Opus Software » Sun Mar 04, 2018 11:37 am

When viewing a distant location, possibly using an Observer view but could be using a Custom view at a fixed lat/lon location, and updating the weather using a dynamic weather theme with the WeatherSetModeTheme SimConnect function, the weather at the observed remote location is incorrect.

It appears to show local weather and not the weather associated with the distant location. For example, if the local site is foggy and the distant 'observed' site is clear then the local fog is displayed at the distant location after the weather theme is injected. Reading the METAR from the distant location also indicates incorrect weather.

Everything is perfect when the distant location is not being observed at the time. The correct weather is displayed if the distant location is observed after the weather theme is injected, and of course the METAR from the distant site is correct.

The problem happens every time when injecting weather as a dynamic theme using the SimConnect WeatherSetModeTheme function. The weather at the distant 'observed' location can be set correctly using the WeatherSetObservation function to inject a METAR. However, as I've already reported there are problems using this function when the location is not an 'in built' weather station. See my reported problems with using the WeatherSetObservation function.

As a recap, I reported the WeatherSetObservation function does not work when used with a non-zero delay at any user created weather stations. Furthermore when using a zero delay parameter the WeatherSetObservation function causes visible changes to the local weather even though the distant site is a great distance away (100 miles).

Regards
Stephen

Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 1 guest