fNormalJ has wrong value.

kimpaul
Posts: 6
Joined: Thu May 25, 2017 11:40 am

fNormalJ has wrong value.

Postby kimpaul » Mon Jul 17, 2017 8:44 am

Hi,

I'm using RequestGroundInfoOnSimObject for get the SIMCONNECT_DATA_GROUND_INFO.

The class variables like fAlt, eSurfaceType, eSurfaceCondition has correct value.

But the fNormal value something doubtable, specially fNormalJ.

fNormalI, fNormalK value was changed range in 0.0 ~ 0.3.

only fNormalJ value was changed range in 0.95 ~ 1.0.

I think fNormalJ mean up vector like(0, 1, 0). So it has 1.0 value in runway. It is Good.

But In slope like hills, the value changed very small. I want get correct value.

Please help me for care of this problem.

Thank you!

Clifton Crane
Lockheed Martin
Posts: 755
Joined: Tue Sep 25, 2012 2:34 pm

Re: fNormalJ has wrong value.

Postby Clifton Crane » Mon Jul 17, 2017 8:21 pm

Hello,

Can you provide a test case/location where you believe the SimConnect call is providing inaccurate normal information?

Thanks.
Clifton Crane
Prepar3D® Software Engineer

kimpaul
Posts: 6
Joined: Thu May 25, 2017 11:40 am

Re: fNormalJ has wrong value.

Postby kimpaul » Thu Jul 20, 2017 10:50 am

Thank you for reply.

The test case or location is not matter.

Because I never see that the fNormalJ has value of under 0.95.

Another variable like fNormalI, fNormalK has changed range in 0.0 ~ 0.3. It has 0.3 gap.

But fNormalJ's gap is only 0.05.

If my expecting is wrong you can talk to me.

Thank you!

kimpaul
Posts: 6
Joined: Thu May 25, 2017 11:40 am

Re: fNormalJ has wrong value.

Postby kimpaul » Tue Jul 25, 2017 8:28 am

Hello,

Can you provide a test case/location where you believe the SimConnect call is providing inaccurate normal information?

Thanks.
Thank you for reply.

The test case or location is not matter.

Because I never see that the fNormalJ has value of under 0.95.

Another variable like fNormalI, fNormalK has changed range in 0.0 ~ 0.3. It has 0.3 gap.

But fNormalJ's gap is only 0.05.

If my expecting is wrong you can talk to me.

Thank you!


Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 3 guests