SimConnect Won't Install & RevSim TQ Issue. (Windows 10)

Posts: 8
Joined: Fri Apr 05, 2013 3:51 pm

SimConnect Won't Install & RevSim TQ Issue. (Windows 10)

Postby HowardChristian » Tue Jan 10, 2017 3:21 pm

SimConnect Won't Install & Revolution_Sim TQ Issue.

Hi, I'm running P3D V3.49 on one of my w10 pcS.
I've tried installing all three SimConnect.msi Versions from the RTM,SP1 & the XPACK folders.
Initially the install seems to be going thru a normal install but they have not actually installed anywhere on my PC.
Checked the proper AppData folders etc. but nowehere.

Not listed in the Windows Uninstall Programs area either.
Rebooted the PC & tried to install again but this time all I get is an extremely fast flash & no idea what it does but it it doesn't even do the usual install progress now.

I also tried to install Simconnect on a separate PC, it running Windows 10 too. This PC does not have Flightsim on it but does have Sim-Avionics. Attempting to install SimConnect on this PC is identical issues as noted above.

ALSO Elevator Trim issue with Revolution_Sim TQ...

My REVOLUTION-SIM TQ for some reason the Trim Wheels will not turn when I press the Elevator Trim buttons on the Yoke.
The Buttons are recognised by FSUIPC but they may not be configured as I had to do a full windows 10 & P3D v3.49 reinstall recently. I did restore my FSUIPC.ini & my SIOC.ssi files but something's gone a miss.

i don't recall how it was setup originally, someone else did that for me. Anyone else with a RevolutionSim TQ that might be able to advise how to get the Trim Wheels moving with the Yoke Buttons?

My TQ has TWO Cards inside, one is a Bodinar BU0836 with the Buttons, Spoiler etc & the other an OpenCockpits card handles the Motors.

When I first Open SIOC & load P3D the Trim Wheels do initially turn fine. But the Yoke Trim Buttons do nothing I suspect it maybe FSUIPC settings but should I need to set them in the FSUIPC Buttons & switches Tab what OFFSETS & what Paramaters should I use?

and do I need to have SimConnect Installed for my TQ?

Thanks so much for any help.

Adam Breed
Lockheed Martin
Posts: 1382
Joined: Mon Sep 20, 2010 6:17 pm

Re: SimConnect Won't Install & RevSim TQ Issue. (Windows 10)

Postby Adam Breed » Tue Jan 10, 2017 4:03 pm

Hi HC,

The legacy SimConnect installers are light weight and do not include an end user facing application.

After installing, do any of them appear in Program and Features?

In regards to your control issues, since you are using FSUIPC you will want to work with that developer directly. FSUIPC does not use either of our two native controller input methods. Still, switching from Raw Input to the DirectInput API via Options > Settings > Controls > Other Tab might produce better results.

Prepar3D® Engineering Project Manager

Posts: 8
Joined: Fri Apr 05, 2013 3:51 pm

Re: SimConnect Won't Install & RevSim TQ Issue. (Windows 10)

Postby HowardChristian » Wed Jan 11, 2017 9:06 am

No SimConnect does not show up in Programs & Features. Not on any of my W10 computers that I I've tried installing it on.

Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 3 guests