P3Dv4.2 VR Single Pass Rendering Mode Issue

For all topics that don't fit into another category. Note that we cannot promise that any of these posts will be responded to by our development team.
powayjoe
Posts: 28
Joined: Tue Oct 08, 2013 9:49 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby powayjoe » Fri Mar 02, 2018 3:58 pm

@Raylemus,
Just to clarify - are the visuals fine when in VR Stereo mode and then not when in Single Pass?
From what I and a few others stated, yes Stereo Mode eliminates the issue. I t appears the issue has to do with the new Single Pass Mode. Just be sure to pick Stereo Mode and the next time you launch P3D it remembers the last choice through a config setting.

I have since rolled back to v4.1. I believe the latest FI verse 1.92 works fine with both P3Dv4.2 and v4.1

Joe
I5-2500K 4.5Ghz, GTX-1070 OC, Corsair Vengeance 2133Mhz, SSD, Oculus Rift, 40 inch 4K Screen, Saitek Equiptment, SPAD.next, VoiceAttack, ChasePlane

Kevin Cartrette
Lockheed Martin
Posts: 428
Joined: Tue Aug 14, 2012 6:47 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Kevin Cartrette » Fri Mar 02, 2018 7:15 pm

Hey All,

Thank you for all the information, we narrowed down the issue to an instancing problem with single pass rendering. We have corrected this issue inside internal builds.

For the time being if you are experiencing to many issues with single pass use the stereo mode. We are still actively working to improve single pass rendering along with other rendering optimizations for VR. Thank you again for your patience and feedback.

Thanks,
-Kevin.
Prepar3D Graphics Software Engineer

whitav8
Posts: 188
Joined: Sat Nov 06, 2010 6:14 am

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby whitav8 » Sat Mar 03, 2018 2:22 am

@Kevin,
Sure would like a VR only Hotfix so those of us that reported the issue can verify that we think you have found all the issues.

Thanks

Dave

cannow
Posts: 66
Joined: Mon Nov 25, 2013 5:51 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby cannow » Sat Mar 03, 2018 10:39 am

Thanks kevin glad you can recreate . I do hope you can sort with a hotfix and not wait for next release which is probably 6 months away . The mode looks great. Well done.

raylemus
Posts: 12
Joined: Thu Apr 17, 2014 4:21 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby raylemus » Sat Mar 03, 2018 4:00 pm

Yeah Kevin! Please shoot us a hotfix for this. It totally sucks to fly without VR man! :-)

Ray

powayjoe
Posts: 28
Joined: Tue Oct 08, 2013 9:49 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby powayjoe » Sat Mar 03, 2018 4:36 pm

Thanks for taking this on and finding a solution.

I hope LM will consider at least adding zoom to native VR and the ability to open pop ups such as ATC, GTN 750 and CDUs as an example. As mentioned earlier in the posting FlyInside does this and more very well and has me still preferring their solution.

Look forward to SPR hopefully in a hotfix

Joe
I5-2500K 4.5Ghz, GTX-1070 OC, Corsair Vengeance 2133Mhz, SSD, Oculus Rift, 40 inch 4K Screen, Saitek Equiptment, SPAD.next, VoiceAttack, ChasePlane

Bingo41
Posts: 15
Joined: Fri Jan 13, 2012 9:29 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Bingo41 » Sat Mar 03, 2018 4:44 pm

I agree with Joe above,

1) Add a zoom feature (Offsets reduced resolution of VR......similar to FlyInside, great for finding tiny Orbx airports off in the distance).
2) Add ability to handle popups (like PMDG CDU, for example), and be able to interact with them.

Bill Clark

whitav8
Posts: 188
Joined: Sat Nov 06, 2010 6:14 am

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby whitav8 » Sun Mar 04, 2018 7:10 pm

@VR folks,
Those are great ideas - zoom and popup windows - and maybe L-M can implement them. How about opening a new topic about those issues so we can continue this one and focus on the correction of the Single Pass Rendering artifacts.

Thanks

Dave W.

raylemus
Posts: 12
Joined: Thu Apr 17, 2014 4:21 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby raylemus » Tue Mar 06, 2018 12:26 am

Man I always knew I get special issues with my computer. Well, I had a chance to toy with the VR settings, and I’m getting the visual issues in stereo mode, not in single pass rendering mode! The carriers look good in single pass rendering mode, but as soon as I change to stereo, I get the visual issues. In single pass mode I am seeing the wake on one eye along with the cloud reflections though. Frame rates are surprisingly smooth in both modes. I did make some changes to the Nvidia control panel a few weeks back in order to optimize frame rate settings in VR. Maybe that has something to do with it?

Ray

KUB10
Posts: 18
Joined: Sun Jun 02, 2013 5:56 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby KUB10 » Sun Mar 11, 2018 12:30 pm

Another issue I recognized is, when above FL400 there is a texture loading issues as well. Its like tiles loading constantly around.The problem disapears with using the stereo mode.

User avatar
Kayla Kinzel
Lockheed Martin
Posts: 1000
Joined: Mon Aug 01, 2016 5:59 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Kayla Kinzel » Mon Mar 12, 2018 1:36 pm

Hello,

Thank you all for your feedback and sharing your passion for VR.

If you find any other issues relating to VR (or any area of Prepar3D), please create another topic. This helps us stay organized and makes new issues visible.

Thanks,
Kayla
Prepar3D® Software Engineer

whitav8
Posts: 188
Joined: Sat Nov 06, 2010 6:14 am

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby whitav8 » Mon Mar 12, 2018 2:23 pm

@Kayla,
Thanks much for the support on this topic of Single Pass rendering issues only. I actually think that most of the discussion has stayed really focused - that being artifacts (strange objects in the air or flickering airport buildings) and other issues (like the sun reflection on water) that seem to go away when returning just to Stereo mode.
We certainly would appreciate a hotfix since L-M indicated they have found the instancing problem and fixed it. If it was treated as a beta then we could feedback if we agree that the issues are gone.

Thanks much

Dave W.

KUB10
Posts: 18
Joined: Sun Jun 02, 2013 5:56 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby KUB10 » Tue Mar 13, 2018 11:05 am

Another issue I recognized is, when above FL400 there is a texture loading issues as well. Its like tiles loading constantly around.The problem disapears with using the stereo mode.
Further information, could be the haze which is loading like tiles. Again above FL400.

powayjoe
Posts: 28
Joined: Tue Oct 08, 2013 9:49 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby powayjoe » Wed Mar 14, 2018 3:46 pm

@Kayla,
Thanks much for the support on this topic of Single Pass rendering issues only. I actually think that most of the discussion has stayed really focused - that being artifacts (strange objects in the air or flickering airport buildings) and other issues (like the sun reflection on water) that seem to go away when returning just to Stereo mode.
We certainly would appreciate a hotfix since L-M indicated they have found the instancing problem and fixed it. If it was treated as a beta then we could feedback if we agree that the issues are gone.

Thanks much

Dave W.
Since I started this post I agree completely.

I was wondering if LM has actually found a solution and if so why not a hot fix?

Thanks again
Joe
I5-2500K 4.5Ghz, GTX-1070 OC, Corsair Vengeance 2133Mhz, SSD, Oculus Rift, 40 inch 4K Screen, Saitek Equiptment, SPAD.next, VoiceAttack, ChasePlane

KUB10
Posts: 18
Joined: Sun Jun 02, 2013 5:56 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby KUB10 » Sat Mar 17, 2018 2:04 pm

@Kayla,
Thanks much for the support on this topic of Single Pass rendering issues only. I actually think that most of the discussion has stayed really focused - that being artifacts (strange objects in the air or flickering airport buildings) and other issues (like the sun reflection on water) that seem to go away when returning just to Stereo mode.
We certainly would appreciate a hotfix since L-M indicated they have found the instancing problem and fixed it. If it was treated as a beta then we could feedback if we agree that the issues are gone.

Thanks much

Dave W.
Since I started this post I agree completely.

I was wondering if LM has actually found a solution and if so why not a hot fix?

Thanks again
Joe
Actually was wondering the same, or do they waiting to correct it in 4.3, hmmmm...

Sven


Return to “Miscellaneous”

Who is online

Users browsing this forum: Google [Bot] and 3 guests